XSS vulnerability with translator
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| flarum | core | 1.0.0 to before 1.0.2 | 1.0.2 | Patch available | CNA |
| — | flarum/core (Packagist) | 1.0.0 to before 1.0.2 | 1.0.2 | Patch available | GHSA-5qjq-69w6-fg57 |
- core Vendorflarum Affected 1.0.0 to before 1.0.2 Fixed in 1.0.2 Patch available CNA
- flarum/core (Packagist) Vendor— Affected 1.0.0 to before 1.0.2 Fixed in 1.0.2 Patch available GHSA-5qjq-69w6-fg57
Remediation
- Fix · CNA core (flarum) Fixed in 1.0.2
- Fix · GHSA-5qjq-69w6-fg57 flarum/core (Packagist) Fixed in 1.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32671
- 2026-10-03 Alias added: GHSA-5qjq-69w6-fg57
References
More Flarum vulnerabilities
- TI-2023-08736 Post mentions can be used to read any post on the forum without access control CVSS 3.1HIGH 7.7
- TI-2025-20573 Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite CVSS 3.1MEDIUM 6.8
- TI-2022-20279 Cross site scripting vulnerability with discussion titles in flarum CVSS 3.1CRITICAL 9.0
- TI-2019-09878 Flarum before 0.1.0-beta.9 allows CSRF against all POST endpoints, as demonstrated by changing admin settings. CVSS 3.0HIGH 8.8
- TI-2019-08604 User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens. CVSS 3.0HIGH 7.5
- TI-2023-20923 Server-Side Request Forgery via Avatar upload in flarum CVSS 3.1HIGH 7.1
Sources
- CVE-2021-32671 · CVE Program
- CVE-2021-32671 · NVD
- FIRST EPSS
- GHSA-5qjq-69w6-fg57 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences