Server-Side Request Forgery via Avatar upload in flarum
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-98.
Summary
Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. This has been patched in Flarum version 1.8.0. Users are advised to upgrade. Users unable to upgrade may disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs as a temporary workaround for the SSRF aspect of the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| flarum | framework | before 1.8.0 | 1.8.0 | Patch available | CNA |
| — | flarum/core (Packagist) | before 1.8.0 | 1.8.0 | Patch available | GHSA-67c6-q4j4-hccg |
| — | flarum/framework (Packagist) | before 1.8.0 | 1.8.0 | Patch available | GHSA-67c6-q4j4-hccg |
- framework Vendorflarum Affected before 1.8.0 Fixed in 1.8.0 Patch available CNA
- flarum/core (Packagist) Vendor— Affected before 1.8.0 Fixed in 1.8.0 Patch available GHSA-67c6-q4j4-hccg
- flarum/framework (Packagist) Vendor— Affected before 1.8.0 Fixed in 1.8.0 Patch available GHSA-67c6-q4j4-hccg
Remediation
- Fix · CNA framework (flarum) Fixed in 1.8.0
- Fix · GHSA-67c6-q4j4-hccg flarum/core (Packagist) Fixed in 1.8.0 Advisory →
- Fix · GHSA-67c6-q4j4-hccg flarum/framework (Packagist) Fixed in 1.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40033
- 2026-10-03 Alias added: GHSA-67c6-q4j4-hccg
References
More Flarum vulnerabilities
- TI-2021-12339 XSS vulnerability with translator CVSS 3.1CRITICAL 10.0
- TI-2023-08736 Post mentions can be used to read any post on the forum without access control CVSS 3.1HIGH 7.7
- TI-2025-20573 Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite CVSS 3.1MEDIUM 6.8
- TI-2022-20279 Cross site scripting vulnerability with discussion titles in flarum CVSS 3.1CRITICAL 9.0
- TI-2019-09878 Flarum before 0.1.0-beta.9 allows CSRF against all POST endpoints, as demonstrated by changing admin settings. CVSS 3.0HIGH 8.8
- TI-2019-08604 User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens. CVSS 3.0HIGH 7.5
Sources
- CVE-2023-40033 · CVE Program
- CVE-2023-40033 · NVD
- FIRST EPSS
- GHSA-67c6-q4j4-hccg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences