Vulnerability in Lua Debugger in Redis
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-125 and the CVSS impact.
Summary
Redis is an open source, in-memory database that persists on disk. When using the Redis Lua Debugger, users can send malformed requests that cause the debugger’s protocol parser to read data beyond the actual buffer. This issue affects all versions of Redis with Lua debugging support (3.2 or newer). The problem is fixed in versions 6.2.6, 6.0.16 and 5.0.14.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Redis | redis | 3.2.0 to before 5.0.14; 6.0.0 to before 6.0.16; 6.0.0 to before 6.2.6 | 5.0.14, 6.0.16, 6.2.6 | Patch available | CNA |
- redis VendorRedis Affected 3.2.0 to before 5.0.14; 6.0.0 to before 6.0.16; 6.0.0 to before 6.2.6 Fixed in 5.0.14, 6.0.16, 6.2.6 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* | 3.2.0 to before 5.0.14; 6.0.0 to before 6.0.16; 6.2.0 to before 6.2.6 | Vulnerable | Redis |
| cpe:2.3:a:redhat:software_collections:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:a:netapp:management_services_for_element_software:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:management_services_for_netapp_hci:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* Versions 3.2.0 to before 5.0.14; 6.0.0 to before 6.0.16; 6.2.0 to before 6.2.6 Vulnerable ·Redis
- cpe:2.3:a:redhat:software_collections:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:a:netapp:management_services_for_element_software:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:management_services_for_netapp_hci:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:oracle:communications_operations_monitor:4.3:*:*:*:*:*:*:* | 4.3 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:communications_operations_monitor:4.4:*:*:*:*:*:*:* | 4.4 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:communications_operations_monitor:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Oracle |
- cpe:2.3:a:oracle:communications_operations_monitor:4.3:*:*:*:*:*:*:* Versions 4.3 Vulnerable ·Oracle
- cpe:2.3:a:oracle:communications_operations_monitor:4.4:*:*:*:*:*:*:* Versions 4.4 Vulnerable ·Oracle
- cpe:2.3:a:oracle:communications_operations_monitor:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Oracle
Remediation
- Fix · CNA redis (redis) Fixed in 5.0.14, 6.0.16, 6.2.6
Red Hat 3 advisories
- RHSA-2021:4618 Released 2021-11-11 · Red Hat rating ImportantRed Hat Advanced Cluster Management 2.4 images and security updates
- Red Hat Advanced Cluster Management for Kubernetes 2.4 for RHEL 8 rhacm2/acm-grafana-rhel8, rhacm2/acm-must-gather-rhel8, rhacm2/acm-operator-bundle +47
- RHSA-2021:3949 Released 2021-10-20 · Red Hat rating ImportantRed Hat Advanced Cluster Management 2.1.12 security fixes and container updates
- Red Hat Advanced Cluster Management for Kubernetes 2.1 for RHEL 8 rhacm2/acm-must-gather-rhel8
- RHSA-2021:3873 Released 2021-10-14 · Red Hat rating ImportantRed Hat Advanced Cluster Management 2.2.9 security, bug, and container updates
- Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 7 rhacm2/management-ingress-rhel7, rhacm2/memcached-exporter-rhel7, rhacm2/search-aggregator-rhel7 +1
- Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 8 rhacm2/acm-must-gather-rhel8, rhacm2/acm-operator-bundle, rhacm2/acmesolver-rhel8 +47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
redis — FEDORA-2021-61c487f241
8 records Highest priority Priority MEDIUM 6 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-12295 Lua scripts can overflow the heap-based Lua stack in RedisPriority MEDIUM 55
- TI-2021-12343 DoS vulnerability in RedisPriority MEDIUM 49
- TI-2021-12297 Vulnerability in handling large ziplistsPriority MEDIUM 48
- Advisory ·
redis — FEDORA-2021-8913c7900c
8 records Highest priority Priority MEDIUM 6 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-12295 Lua scripts can overflow the heap-based Lua stack in RedisPriority MEDIUM 55
- TI-2021-12343 DoS vulnerability in RedisPriority MEDIUM 49
- TI-2021-12297 Vulnerability in handling large ziplistsPriority MEDIUM 48
Show 1 more group
- Advisory ·
redis — FEDORA-2021-aa94492a09
8 records Highest priority Priority MEDIUM 6 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-12295 Lua scripts can overflow the heap-based Lua stack in RedisPriority MEDIUM 55
- TI-2021-12343 DoS vulnerability in RedisPriority MEDIUM 49
- TI-2021-12297 Vulnerability in handling large ziplistsPriority MEDIUM 48
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat Software Collections | Affected | No fix yet: Fix deferred |
Not affected: 4 products
- Red Hat 3scale API Management Platform 2
- Red Hat Ansible Automation Platform 1.2
- Red Hat Ansible Tower 3
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32672
References
Patch 2
More Redis vulnerabilities
- TI-2022-00463 Missing authorization in Debian redis KEVCVSS 3.1CRITICAL 10.0
- TI-2025-31759 Redis Lua Use-After-Free may lead to remote code execution CVSS 3.1CRITICAL 10.0
- TI-2023-18618 Heap overflow in COMMAND GETKEYS and ACL evaluation in Redis CVSS 3.1HIGH 8.8
- TI-2024-20813 Lua library commands may lead to stack overflow and RCE in Redis CVSS 3.1HIGH 8.8
- TI-2022-08647 Heap overflow issue with the Lua cjson library used by Redis CVSS 3.1HIGH 8.8
- TI-2022-08549 Lua scripts can be manipulated to overcome ACL rules in Redis CVSS 3.1HIGH 7.8
Sources
- CVE-2021-32672 · CVE Program
- CVE-2021-32672 · NVD
- FIRST EPSS
- CVE-2021-32672 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences