Read the docs
TI-2021-12437 Aliases CVE-2021-32770GHSA-rqjw-p5vr-c695

Basic-auth app bundle credential exposure in gatsby-source-wordpress

Priority LOW 36CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Gatsby is a framework for building websites. The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced in [email protected] and [email protected] which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`. One may manually edit the app.js file post-build as a workaround.

Why it matters now

EPSS 0.01414 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed gatsby (gatsbyjs): 4.0.8, 5.9.2gatsby-source-wordpress (npm): 4.0.8, 5.9.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
gatsbyjsgatsbybefore 4.0.8; 5.0.0 to before 5.9.24.0.8, 5.9.2Patch availableCNA
—gatsby-source-wordpress (npm)before 4.0.84.0.8Patch availableGHSA-rqjw-p5vr-c695
—gatsby-source-wordpress (npm)5.0.0 to before 5.9.25.9.2Patch availableGHSA-rqjw-p5vr-c695
  • gatsby Vendorgatsbyjs Affected before 4.0.8; 5.0.0 to before 5.9.2 Fixed in 4.0.8, 5.9.2 Patch available CNA
  • gatsby-source-wordpress (npm) Vendor— Affected before 4.0.8 Fixed in 4.0.8 Patch available GHSA-rqjw-p5vr-c695
  • gatsby-source-wordpress (npm) Vendor— Affected 5.0.0 to before 5.9.2 Fixed in 5.9.2 Patch available GHSA-rqjw-p5vr-c695

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:gatsbyjs:gatsby-source-wordpress:*:*:*:*:*:node.js:*:*before 4.0.8; 5.0.0 to before 5.9.2Vulnerablegatsbyjs
  • cpe:2.3:a:gatsbyjs:gatsby-source-wordpress:*:*:*:*:*:node.js:*:* Versions before 4.0.8; 5.0.0 to before 5.9.2 Vulnerable ·gatsbyjs

Remediation

  • Fix · CNA gatsby (gatsbyjs) Fixed in 4.0.8, 5.9.2
  • Fix · GHSA-rqjw-p5vr-c695 gatsby-source-wordpress (npm) Fixed in 4.0.8 Advisory →
  • Fix · GHSA-rqjw-p5vr-c695 gatsby-source-wordpress (npm) Fixed in 5.9.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-32770
  2. 2026-10-03 Alias added: GHSA-rqjw-p5vr-c695

References

Sources