Remote code execution in squirrelly
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Squirrelly is a template engine implemented in JavaScript that works out of the box with ExpressJS. Squirrelly mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options remote code execution may be triggered in downstream applications. This issue is fixed in version 9.0.0. For complete details refer to the referenced GHSL-2021-023.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| squirrellyjs | squirrelly | 9.0.0 to before 9.0.0 | 9.0.0 | Patch available | CNA |
| — | squirrelly (npm) | before 9.0.0 | 9.0.0 | Patch available | GHSA-q8j6-pwqx-pm96 |
- squirrelly Vendorsquirrellyjs Affected 9.0.0 to before 9.0.0 Fixed in 9.0.0 Patch available CNA
- squirrelly (npm) Vendor— Affected before 9.0.0 Fixed in 9.0.0 Patch available GHSA-q8j6-pwqx-pm96
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:squirrelly:squirrelly:8.0.8:*:*:*:*:*:*:* | 8.0.8 | Vulnerable | Squirrelly |
- cpe:2.3:a:squirrelly:squirrelly:8.0.8:*:*:*:*:*:*:* Versions 8.0.8 Vulnerable ·Squirrelly
Remediation
- Fix · CNA squirrelly (squirrellyjs) Fixed in 9.0.0
- Fix · GHSA-q8j6-pwqx-pm96 squirrelly (npm) Fixed in 9.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32819
- 2026-10-03 Alias added: GHSA-q8j6-pwqx-pm96
References
Advisory 2
More Squirrelly vulnerabilities
- TI-2024-26927 squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-32819 · CVE Program
- CVE-2021-32819 · NVD
- FIRST EPSS
- GHSA-q8j6-pwqx-pm96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences