squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code…
Priority MEDIUM 51CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code injection vulnerability via the component options.varName.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01126 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed squirrelly (npm): 9.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | squirrelly (npm) | 9.0.0 to before 9.1.0 | 9.1.0 | Patch available | GHSA-w5pw-gmcw-rfc8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- squirrelly (npm) Vendor— Affected 9.0.0 to before 9.1.0 Fixed in 9.1.0 Patch available GHSA-w5pw-gmcw-rfc8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:squirrelly:squirrelly:9.0.0:*:*:*:*:node.js:*:* | 9.0.0 | Vulnerable | Squirrelly |
- cpe:2.3:a:squirrelly:squirrelly:9.0.0:*:*:*:*:node.js:*:* Versions 9.0.0 Vulnerable ·Squirrelly
Remediation
- Fix · GHSA-w5pw-gmcw-rfc8 squirrelly (npm) Fixed in 9.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-40453
- 2026-10-03 Alias added: GHSA-w5pw-gmcw-rfc8
References
More Squirrelly vulnerabilities
- TI-2021-12484 Remote code execution in squirrelly CVSS 3.1HIGH 8.8
Sources
- CVE-2024-40453 · CVE Program
- CVE-2024-40453 · NVD
- FIRST EPSS
- GHSA-w5pw-gmcw-rfc8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences