Server-side request forgery in SAP NetWeaver Development Infrastructure
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Server-Side Request Forgery (SSRF) vulnerability has been detected in the SAP NetWeaver Development Infrastructure Component Build Service versions - 7.11, 7.20, 7.30, 7.31, 7.40, 7.50The SAP NetWeaver Development Infrastructure Component Build Service allows a threat actor who has access to the server to perform proxy attacks on server by sending crafted queries. Due to this, the threat actor could completely compromise sensitive data residing on the Server and impact its availability.Note: The impact of this vulnerability depends on whether SAP NetWeaver Development Infrastructure (NWDI) runs on the intranet or internet. The CVSS score reflects the impact considering the worst-case scenario that it runs on the internet.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Development Infrastructure (Component Build Service) | before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 | 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver Development Infrastructure (Component Build Service) VendorSAP Affected before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_development_infrastructure:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_development_infrastructure:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_development_infrastructure:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_development_infrastructure:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_development_infrastructure:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_development_infrastructure:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_development_infrastructure:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_development_infrastructure:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_development_infrastructure:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_development_infrastructure:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_development_infrastructure:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_development_infrastructure:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Development Infrastructure (Component Build Service) (SAP SE) Fixed in 7.11, 7.20, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33690
- 2026-10-03 Alias added: GHSA-76pj-fv2h-qvfg
References
More SAP Netweaver Development Infrastructure vulnerabilities
- TI-2013-05609 Unrestricted file upload vulnerability in the SAP NetWeaver Development Infrastructure… CVSS 2.0HIGH 9.3
- TI-2022-12053 Cross-site scripting in SAP NetWeaver Development Infrastructure CVSS 3.1MEDIUM 6.1
- TI-2021-13065 Cross-site scripting in SAP NetWeaver Development Infrastructure CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-33690 · CVE Program
- CVE-2021-33690 · NVD
- FIRST EPSS
- GHSA-76pj-fv2h-qvfg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences