Read the docs
TI-2021-13065 Aliases CVE-2021-33691GHSA-h5vp-8vfv-4cgp

Cross-site scripting in SAP NetWeaver Development Infrastructure

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

NWDI Notification Service versions - 7.31, 7.40, 7.50, does not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability.SAP NetWeaver Development Infrastructure Notification Service allows a threat actor to send crafted scripts to a victim. If the victim has an active session when the crafted script gets executed, the threat actor could compromise information in victims session, and gain access to some sensitive information also.

Why it matters now

EPSS 0.00638 50th percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Development Infrastructure (Notification Service) (SAP SE): 7.31, 7.40, 7.50

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SAPSAP NetWeaver Development Infrastructure (Notification Service)before 7.31; before 7.40; before 7.507.31, 7.40, 7.50Patch availableCNA
  • SAP NetWeaver Development Infrastructure (Notification Service) VendorSAP Affected before 7.31; before 7.40; before 7.50 Fixed in 7.31, 7.40, 7.50 Patch available CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:sap:netweaver_development_infrastructure:7.31:*:*:*:*:*:*:*7.31VulnerableSAP
cpe:2.3:a:sap:netweaver_development_infrastructure:7.40:*:*:*:*:*:*:*7.40VulnerableSAP
cpe:2.3:a:sap:netweaver_development_infrastructure:7.50:*:*:*:*:*:*:*7.50VulnerableSAP
  • cpe:2.3:a:sap:netweaver_development_infrastructure:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_development_infrastructure:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_development_infrastructure:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP

Remediation

  • Fix · CNA SAP NetWeaver Development Infrastructure (Notification Service) (SAP SE) Fixed in 7.31, 7.40, 7.50

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-33691
  2. 2026-10-03 Alias added: GHSA-h5vp-8vfv-4cgp
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2021-13064 Server-side request forgery in SAP NetWeaver Development Infrastructure CVSS 3.1CRITICAL 9.9
  • TI-2013-05609 Unrestricted file upload vulnerability in the SAP NetWeaver Development Infrastructure… CVSS 2.0HIGH 9.3
  • TI-2022-12053 Cross-site scripting in SAP NetWeaver Development Infrastructure CVSS 3.1MEDIUM 6.1

Sources