Cross Site Scripting (XSS).
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting (XSS). vulnerability exists in Microweber CMS 1.2.7 via the Login form, which could let a malicious user execute Javascript by Inserting code in the request form.
Why it matters now
EPSS 0.01064 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed microweber/microweber (Packagist): 1.2.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | microweber/microweber (Packagist) | before 1.2.8 | 1.2.8 | Patch available | GHSA-w7x8-cq7r-g5g9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- microweber/microweber (Packagist) Vendor— Affected before 1.2.8 Fixed in 1.2.8 Patch available GHSA-w7x8-cq7r-g5g9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microweber:microweber:1.2.7:*:*:*:*:*:*:* | 1.2.7 | Vulnerable | microweber |
- cpe:2.3:a:microweber:microweber:1.2.7:*:*:*:*:*:*:* Versions 1.2.7 Vulnerable ·microweber
Remediation
- Fix · GHSA-w7x8-cq7r-g5g9 microweber/microweber (Packagist) Fixed in 1.2.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33988
- 2026-10-03 Alias added: GHSA-w7x8-cq7r-g5g9
References
More Microweber vulnerabilities
- TI-2023-01763 Command Injection in microweber/microweber CVSS 3.1CRITICAL 9.8
- TI-2023-02100 Improper Privilege Management in microweber/microweber CVSS 3.1HIGH 8.8
- TI-2022-14518 Microweber v1.2.15 was discovered to allow attackers to perform an account takeover via a host header injection attack. CVSS 3.1HIGH 8.8
- TI-2023-04891 Use of Hard-coded Credentials in microweber/microweber CVSS 3.1HIGH 7.5
- TI-2025-37870 Microweber CMS 2.0 has Weak Password Requirements. CVSS 3.1HIGH 8.3
- TI-2022-04247 Cross-site Scripting (XSS) - Stored in microweber/microweber CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-33988 · CVE Program
- CVE-2021-33988 · NVD
- FIRST EPSS
- GHSA-w7x8-cq7r-g5g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences