CSRF in WP Fluent Forms < 3.6.67 allows stored XSS and Privilege Escalation
Priority HIGH 73CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352 and CWE-79.
Summary
The WP Fluent Forms plugin < 3.6.67 for WordPress is vulnerable to Cross-Site Request Forgery leading to stored Cross-Site Scripting and limited Privilege Escalation due to a missing nonce check in the access control function for administrative AJAX actions
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02633 85th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed WP Fluent Forms (WP Manage Ninja): 3.6.67
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WP ManageNinja LLC | WP Fluent Forms | 3.6.67 to before 3.6.67 | 3.6.67 | Patch available | CNA |
- WP Fluent Forms VendorWP ManageNinja LLC Affected 3.6.67 to before 3.6.67 Fixed in 3.6.67 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:*:*:* | before 3.6.67 | Vulnerable | Fluentforms |
- cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:*:*:* Versions before 3.6.67 Vulnerable ·Fluentforms
Remediation
- Fix · CNA WP Fluent Forms (WP Manage Ninja) Fixed in 3.6.67
Timeline
- 2026-10-02 Threatist record created from CVE-2021-34620
- 2026-10-03 Alias added: GHSA-pp6p-gh63-62xr
References
More WP ManageNinja LLC vulnerabilities
- TI-2022-04342 FluentAuth < 1.0.2 - Bypass blocks by IP Spoofing CVSS 3.1HIGH 7.5
- TI-2024-11836 Ninja Tables < 5.0.17 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-00211 FluentSMTP < 2.2.3 - Stored XSS via Email Logs CVSS 3.1MEDIUM 5.4
- TI-2026-51633 Ninja Tables Pro 5.2.11 Embedded Malicious Code via Tampered Plugin Build CVSS 4.0CRITICAL 9.3
- TI-2026-51632 Fluent Forms Pro 6.2.7 Embedded Malicious Code via Tampered Plugin Build CVSS 4.0CRITICAL 9.3
- TI-2026-74728 Privilege escalation in WordPress Fluent CRM plugin CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-34620 · CVE Program
- CVE-2021-34620 · NVD
- FIRST EPSS
- GHSA-pp6p-gh63-62xr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences