Magento Commerce Customer Edition Improper Input Validation Could Lead To Remote Code Execution
Priority MEDIUM 44CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability while saving a customer's details with a specially crafted file. An authenticated attacker with admin privileges can leverage this vulnerability to achieve remote code execution.
Why it matters now
EPSS 0.02807 86th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.7-p1, 2.4.2-p2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento Commerce | up to 2.4.2; up to 2.4.2-p1; up to 2.3.7; up to None | — | No fix listed | CNA |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-gvfx-9m9v-h839 |
| — | magento/community-edition (Packagist) | before 2.3.7-p1 | 2.3.7-p1 | Patch available | GHSA-gvfx-9m9v-h839 |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-gvfx-9m9v-h839 |
| — | magento/community-edition (Packagist) | 2.4.2-p1 to before 2.4.2-p2 | 2.4.2-p2 | Patch available | GHSA-gvfx-9m9v-h839 |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-gvfx-9m9v-h839 |
- Magento Commerce VendorAdobe Affected up to 2.4.2; up to 2.4.2-p1; up to 2.3.7; up to None Fixed in — No fix listed CNA
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-gvfx-9m9v-h839
- magento/community-edition (Packagist) Vendor— Affected before 2.3.7-p1 Fixed in 2.3.7-p1 Patch available GHSA-gvfx-9m9v-h839
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-gvfx-9m9v-h839
- magento/community-edition (Packagist) Vendor— Affected 2.4.2-p1 to before 2.4.2-p2 Fixed in 2.4.2-p2 Patch available GHSA-gvfx-9m9v-h839
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-gvfx-9m9v-h839
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:adobe_commerce:*:*:*:*:*:*:*:* | 2.3.0 – 2.3.7; 2.4.0 – 2.4.2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:adobe_commerce:2.4.2:p1:*:*:*:*:*:* | 2.4.2 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:* | 2.3.0 – 2.3.7; 2.4.0 – 2.4.2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_open_source:2.4.2:p1:*:*:*:*:*:* | 2.4.2 p1 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:adobe_commerce:*:*:*:*:*:*:*:* Versions 2.3.0 – 2.3.7; 2.4.0 – 2.4.2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:adobe_commerce:2.4.2:p1:*:*:*:*:*:* Versions 2.4.2 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:* Versions 2.3.0 – 2.3.7; 2.4.0 – 2.4.2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_open_source:2.4.2:p1:*:*:*:*:*:* Versions 2.4.2 p1 Vulnerable ·Adobe
Remediation
- Fix · GHSA-gvfx-9m9v-h839 magento/community-edition (Packagist) Fixed in 2.3.7-p1 Advisory →
- Fix · GHSA-gvfx-9m9v-h839 magento/community-edition (Packagist) Fixed in 2.4.2-p2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36025
- 2026-10-03 Alias added: GHSA-gvfx-9m9v-h839
References
More Adobe Commerce vulnerabilities
- TI-2021-14470 Magento Commerce XML Injection Vulnerability In The 'City' Field Could Lead To Remote Code Execution CVSS 3.1CRITICAL 9.8
- TI-2021-14490 Magento Commerce Improper Input Validation Could Lead To Remote Code Execution CVSS 3.1CRITICAL 9.1
- TI-2021-14483 Magento Commerce Widgets Module XML Injection Vulnerability Could Lead To Remote Code Execution CVSS 3.1CRITICAL 9.1
- TI-2021-14478 Magento Commerce XML Injection Vulnerability Could Lead To Remote Code Execution CVSS 3.1CRITICAL 9.1
- TI-2021-14474 Magento Commerce Improper Neutralization of Special Elements Used In A Command CVSS 3.1CRITICAL 9.1
- TI-2021-14472 Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution CVSS 3.1CRITICAL 9.1
Sources
- CVE-2021-36025 · CVE Program
- CVE-2021-36025 · NVD
- FIRST EPSS
- GHSA-gvfx-9m9v-h839 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences