Stack-based buffer overflow in Dell Integrated Dell Remote Access Controller
Priority LOW 36CWE-121Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-121 and the CVSS impact.
Summary
iDRAC9 versions prior to 5.00.20.00 and iDRAC8 versions prior to 2.82.82.82 contain a stack-based buffer overflow vulnerability. An authenticated remote attacker with high privileges could potentially exploit this vulnerability to control process execution and gain access to the iDRAC operating system.
Why it matters now
EPSS 0.02208 82nd percentileScored 2026-11-07
Fix Fixed Integrated Dell Remote Access Controller (iDRAC) (Dell): iDRAC8: 2.82.82.82, iDRAC9: 5.00.20.00
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Integrated Dell Remote Access Controller (iDRAC) | before iDRAC8: 2.82.82.82, iDRAC9: 5.00.20.00 | iDRAC8: 2.82.82.82, iDRAC9: 5.00.20.00 | Patch available | CNA |
- Integrated Dell Remote Access Controller (iDRAC) VendorDell Affected before iDRAC8: 2.82.82.82, iDRAC9: 5.00.20.00 Fixed in iDRAC8: 2.82.82.82, iDRAC9: 5.00.20.00 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:integrated_dell_remote_access_controller_8_firmware:*:*:*:*:*:*:*:* | before 2.82.82.82 | Vulnerable | Dell |
| cpe:2.3:h:dell:integrated_dell_remote_access_controller_8:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:integrated_dell_remote_access_controller_9_firmware:*:*:*:*:*:*:*:* | before 5.00.20.00 | Vulnerable | Dell |
| cpe:2.3:h:dell:integrated_dell_remote_access_controller_9:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:integrated_dell_remote_access_controller_8_firmware:*:*:*:*:*:*:*:* Versions before 2.82.82.82 Vulnerable ·Dell
- cpe:2.3:h:dell:integrated_dell_remote_access_controller_8:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:integrated_dell_remote_access_controller_9_firmware:*:*:*:*:*:*:*:* Versions before 5.00.20.00 Vulnerable ·Dell
- cpe:2.3:h:dell:integrated_dell_remote_access_controller_9:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA Integrated Dell Remote Access Controller (iDRAC) (Dell) Fixed in iDRAC8: 2.82.82.82, iDRAC9: 5.00.20.00
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36347
- 2026-10-03 Alias added: GHSA-q5r8-fmxw-rxvr
References
More Dell Integrated Dell Remote Access Controller 8 Firmware vulnerabilities
- TI-2022-08299 Improper input validation in Dell Integrated Dell Remote Access Controller 8 CVSS 3.1HIGH 7.5
- TI-2021-14707 Improper authentication in Dell Integrated Dell Remote Access Controller CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-36347 · CVE Program
- CVE-2021-36347 · NVD
- FIRST EPSS
- GHSA-q5r8-fmxw-rxvr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences