Read the docs
TI-2021-14804 Aliases CVE-2021-36568GHSA-fm6m-fg23-67jq

In certain Moodle products after creating a course, it is possible to add in a arbitrary…

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In certain Moodle products after creating a course, it is possible to add in a arbitrary "Topic" a resource, in this case a "Database" with the type "Text" where its values "Field name" and "Field description" are vulnerable to Cross Site Scripting Stored(XSS). This affects Moodle 3.11 and Moodle 3.10.4 and Moodle 3.9.7.

Why it matters now

EPSS 0.01067 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed moodle/moodle (Packagist): 3.11.10

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)up to 3.9.7—No fix listedGHSA-fm6m-fg23-67jq
—moodle/moodle (Packagist)3.10.0 – 3.10.4—No fix listedGHSA-fm6m-fg23-67jq
—moodle/moodle (Packagist)3.11.0 to before 3.11.103.11.10Patch availableGHSA-fm6m-fg23-67jq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected up to 3.9.7 Fixed in — No fix listed GHSA-fm6m-fg23-67jq
  • moodle/moodle (Packagist) Vendor— Affected 3.10.0 – 3.10.4 Fixed in — No fix listed GHSA-fm6m-fg23-67jq
  • moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.10 Fixed in 3.11.10 Patch available GHSA-fm6m-fg23-67jq

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:3.9.7:*:*:*:*:*:*:*3.9.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.10.4:*:*:*:*:*:*:*3.10.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.11.0:*:*:*:*:*:*:*3.11.0VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:3.9.7:*:*:*:*:*:*:* Versions 3.9.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.10.4:*:*:*:*:*:*:* Versions 3.10.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.11.0:*:*:*:*:*:*:* Versions 3.11.0 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-fm6m-fg23-67jq moodle/moodle (Packagist) Fixed in 3.11.10 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-36568
  2. 2026-10-03 Alias added: GHSA-fm6m-fg23-67jq

References

Sources