Cross-site scripting in Mattermost
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Mattermost 5.38 and earlier fails to sufficiently sanitize clipboard contents, which allows a user-assisted attacker to inject arbitrary web script in product deployments that explicitly disable the default CSP.
Why it matters now
EPSS 0.00631 50th percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server/v5 (Go): 5.39.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | up to 5.38 | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server/v5 (Go) | before 5.39.0 | 5.39.0 | Patch available | GHSA-hv5f-73mr-7vvj |
- Mattermost VendorMattermost Affected up to 5.38 Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server/v5 (Go) Vendor— Affected before 5.39.0 Fixed in 5.39.0 Patch available GHSA-hv5f-73mr-7vvj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | up to 5.38 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions up to 5.38 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-hv5f-73mr-7vvj github.com/mattermost/mattermost-server/v5 (Go) Fixed in 5.39.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-37860
- 2026-10-03 Alias added: GHSA-hv5f-73mr-7vvj
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26233 Malicious remote can add users to arbitrary teams and channels CVSS 3.1HIGH 8.7
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
Sources
- CVE-2021-37860 · CVE Program
- CVE-2021-37860 · NVD
- FIRST EPSS
- GHSA-hv5f-73mr-7vvj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences