Read the docs
TI-2021-15695 Aliases CVE-2021-37937GHSA-4qh7-cr89-jx92

Elasticsearch privilege escalation

Priority LOW 39CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.

Summary

An issue was found with how API keys are created with the Fleet-Server service account. When an API key is created with a service account, it is possible that the API key could be created with higher privileges than intended. Using this vulnerability, a compromised Fleet-Server service account could escalate themselves to a super-user.

Why it matters now

EPSS 0.00714 53rd percentileScored 2026-11-07
Fix Fixed Elasticsearch (Elastic): 7.14.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElasticElasticsearch7.13.0 to before 7.14.07.14.0Patch availableCNA
  • Elasticsearch VendorElastic Affected 7.13.0 to before 7.14.0 Fixed in 7.14.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:*7.13.0 – 7.14.0VulnerableElastic
  • cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* Versions 7.13.0 – 7.14.0 Vulnerable ·Elastic

Remediation

  • Fix · CNA Elasticsearch (Elastic) Fixed in 7.14.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37937
  2. 2026-10-03 Alias added: GHSA-4qh7-cr89-jx92

References

  • TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
  • TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
  • TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
  • TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
  • TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
See all 90 →

Sources