Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting, Security bypass
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-863.
Summary
The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| themefusecom | Brizy - Page Builder | 2.3.11 – 2.3.11; 1.0.127 and later; 1.0.125 – 1.0.125 | — | No fix listed | CNA |
- Brizy - Page Builder Vendorthemefusecom Affected 2.3.11 – 2.3.11; 1.0.127 and later; 1.0.125 – 1.0.125 Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brizy:brizy-page_builder:*:*:*:*:wordpress:*:*:* | before 1.0.1.126 | Vulnerable | themefusecom |
| cpe:2.3:a:brizy:brizy-page_builder:*:*:*:*:*:*:*:* | 1.0.127 – 2.3.11 | Vulnerable | themefusecom |
- cpe:2.3:a:brizy:brizy-page_builder:*:*:*:*:wordpress:*:*:* Versions before 1.0.1.126 Vulnerable ·themefusecom
- cpe:2.3:a:brizy:brizy-page_builder:*:*:*:*:*:*:*:* Versions 1.0.127 – 2.3.11 Vulnerable ·themefusecom
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-38345
- 2026-10-03 Alias added: GHSA-mg85-w8wc-5fvp
References
More themefusecom Brizy-page Builder vulnerabilities
- TI-2021-15953 Brizy <= 2.3.11 Authenticated Unrestricted File Upload and Path Traversal CVSS 3.1HIGH 8.8
- TI-2021-15951 Brizy <= 2.3.11 Authenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-38345 · CVE Program
- CVE-2021-38345 · NVD
- FIRST EPSS
- GHSA-mg85-w8wc-5fvp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences