Remote code execution in Binderhub
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
BinderHub is a kubernetes-based cloud service that allows users to share reproducible interactive computing environments from code repositories. In affected versions a remote code execution vulnerability has been identified in BinderHub, where providing BinderHub with maliciously crafted input could execute code in the BinderHub context, with the potential to egress credentials of the BinderHub deployment, including JupyterHub API tokens, kubernetes service accounts, and docker registry credentials. This may provide the ability to manipulate images and other user created pods in the deployment, with the potential to escalate to the host depending on the underlying kubernetes configuration. Users are advised to update to version 0.2.0-n653. If users are unable to update they may disable the git repo provider by specifying the `BinderHub.repo_providers` as a workaround.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterhub | binderhub | before 0.2.0-n653 | 0.2.0-n653 | Patch available | CNA |
| — | binderhub (PyPI) | before 0.2.0 | 0.2.0 | Patch available | GHSA-9jjr-qqfp-ppwx |
- binderhub Vendorjupyterhub Affected before 0.2.0-n653 Fixed in 0.2.0-n653 Patch available CNA
- binderhub (PyPI) Vendor— Affected before 0.2.0 Fixed in 0.2.0 Patch available GHSA-9jjr-qqfp-ppwx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:binderhub:*:*:*:*:*:*:*:* | before 0.2.0-n653 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:binderhub:*:*:*:*:*:*:*:* Versions before 0.2.0-n653 Vulnerable ·jupyterlab
Remediation
- Fix · CNA binderhub (jupyterhub) Fixed in 0.2.0-n653
- Fix · GHSA-9jjr-qqfp-ppwx binderhub (PyPI) Fixed in 0.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39159
- 2026-10-03 Alias added: GHSA-9jjr-qqfp-ppwx
References
Patch 2
More jupyterhub vulnerabilities
- TI-2025-23499 Jupyter Remote Desktop Proxy makes TigerVNC accessible via the network and not just via a UNIX socket as intended CVSS 4.0CRITICAL 9.0
- TI-2023-10877 JupyterHub's LTI13Authenticator: JWT signature not validated CVSS 3.1CRITICAL 10.0
- TI-2021-18033 Improper Access Control in jupyterhub-firstuseauthenticator CVSS 3.1CRITICAL 9.8
- TI-2021-16546 Code injection in nbgitpuller CVSS 3.1CRITICAL 9.6
- TI-2024-18755 Jupyter Server Proxy's Websocket Proxying does not require authentication CVSS 3.1CRITICAL 9.8
- TI-2024-23295 Jupyter Server Proxy has a reflected XSS issue in host parameter CVSS 3.1CRITICAL 9.7
Sources
- CVE-2021-39159 · CVE Program
- CVE-2021-39159 · NVD
- FIRST EPSS
- GHSA-9jjr-qqfp-ppwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences