Read the docs
TI-2021-17094 Aliases CVE-2021-39864GHSA-94wq-87g6-8h77

Adobe Commerce Cross-Site Request Forgery (CSRF) Could Lead To Unauthorized Cart Addition

Priority LOW 32CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Adobe Commerce versions 2.4.2-p2 (and earlier), 2.4.3 (and earlier) and 2.3.7p1 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via a Wishlist Share Link. Successful exploitation could lead to unauthorized addition to customer cart by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01619 76th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.7-p2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeMagento Commerceup to 2.4.3; up to 2.4.2-p2; up to 2.3.7-p1; up to None—No fix listedCNA
—magento/community-edition (Packagist)2.4.2-p1 – 2.4.2-p2—No fix listedGHSA-94wq-87g6-8h77
—magento/community-edition (Packagist)——No fix listedGHSA-94wq-87g6-8h77
—magento/community-edition (Packagist)before 2.3.7-p22.3.7-p2Patch availableGHSA-94wq-87g6-8h77
—magento/community-edition (Packagist)——No fix listedGHSA-94wq-87g6-8h77
—magento/project-community-edition (Packagist)up to 2.0.2—No fix listedGHSA-94wq-87g6-8h77
  • Magento Commerce VendorAdobe Affected up to 2.4.3; up to 2.4.2-p2; up to 2.3.7-p1; up to None Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.4.2-p1 – 2.4.2-p2 Fixed in — No fix listed GHSA-94wq-87g6-8h77
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-94wq-87g6-8h77
  • magento/community-edition (Packagist) Vendor— Affected before 2.3.7-p2 Fixed in 2.3.7-p2 Patch available GHSA-94wq-87g6-8h77
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-94wq-87g6-8h77
  • magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-94wq-87g6-8h77

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:*up to 2.3.7VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:*2.3.7 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.2:*:*:*:*:*:*:*2.4.2VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.2:p1:*:*:*:*:*:*2.4.2 p1VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.2:p2:*:*:*:*:*:*2.4.2 p2VulnerableAdobe
cpe:2.3:a:adobe:commerce:2.4.3:*:*:*:*:*:*:*2.4.3VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:*up to 2.3.7VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.3.7:p1:*:*:*:*:*:*2.3.7 p1VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.4.2:*:*:*:*:*:*:*2.4.2VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.4.2:p1:*:*:*:*:*:*2.4.2 p1VulnerableAdobe
  • cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions up to 2.3.7 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.2:p1:*:*:*:*:*:* Versions 2.4.2 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.2:p2:*:*:*:*:*:* Versions 2.4.2 p2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:commerce:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:* Versions up to 2.3.7 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.3.7:p1:*:*:*:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.2:p1:*:*:*:*:*:* Versions 2.4.2 p1 Vulnerable ·Adobe
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:adobe:magento_open_source:2.4.2:p2:*:*:*:*:*:*2.4.2 p2VulnerableAdobe
cpe:2.3:a:adobe:magento_open_source:2.4.3:*:*:*:*:*:*:*2.4.3VulnerableAdobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.2:p2:*:*:*:*:*:* Versions 2.4.2 p2 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:magento_open_source:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Adobe

Remediation

  • Fix · GHSA-94wq-87g6-8h77 magento/community-edition (Packagist) Fixed in 2.3.7-p2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-39864
  2. 2026-10-03 Alias added: GHSA-94wq-87g6-8h77

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
  • TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
  • TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
See all 213 →

Sources