Improper verification of communication channel in Eclipse Foundation @theia/plugin-ext
Priority LOW 29CWE-940Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().
Why it matters now
EPSS 0.00737 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @theia/plugin-ext (The Eclipse Foundation): 1.18.0@theia/plugin-ext (npm): 1.18.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Eclipse Foundation | @theia/plugin-ext | before 1.18.0 | 1.18.0 | Patch available | CNA |
| — | @theia/plugin-ext (npm) | before 1.18.0 | 1.18.0 | Patch available | GHSA-w6v7-w58j-pg5r |
- @theia/plugin-ext VendorEclipse Foundation Affected before 1.18.0 Fixed in 1.18.0 Patch available CNA
- @theia/plugin-ext (npm) Vendor— Affected before 1.18.0 Fixed in 1.18.0 Patch available GHSA-w6v7-w58j-pg5r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eclipse:theia:*:*:*:*:*:*:*:* | before 1.18.0 | Vulnerable | Eclipse Foundation |
- cpe:2.3:a:eclipse:theia:*:*:*:*:*:*:*:* Versions before 1.18.0 Vulnerable ·Eclipse Foundation
Remediation
- Fix · CNA @theia/plugin-ext (The Eclipse Foundation) Fixed in 1.18.0
- Fix · GHSA-w6v7-w58j-pg5r @theia/plugin-ext (npm) Fixed in 1.18.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41038
- 2026-10-03 Alias added: GHSA-w6v7-w58j-pg5r
References
More Eclipse Foundation Theia vulnerabilities
- TI-2026-12294 Prototype pollution in Eclipse Theia CVSS 4.0MEDIUM 5.7
- TI-2021-13470 Path traversal in Eclipse Theia CVSS 3.1CRITICAL 9.8
- TI-2020-16550 Cross-site scripting in Eclipse Theia CVSS 3.1CRITICAL 9.6
- TI-2026-10807 Path traversal in Eclipse Theia CVSS 3.1HIGH 7.5
- TI-2026-44283 Information disclosure in Eclipse Theia CVSS 3.1HIGH 7.5
- TI-2026-42788 Path traversal in Eclipse Theia CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41038 · CVE Program
- CVE-2021-41038 · NVD
- FIRST EPSS
- GHSA-w6v7-w58j-pg5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences