File Traversal affecting SVG files on Nextcloud Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, a file traversal vulnerability makes an attacker able to download arbitrary SVG images from the host system, including user provided files. This could also be leveraged into a XSS/phishing attack, an attacker could upload a malicious SVG file that mimics the Nextcloud login form and send a specially crafted link to victims. The XSS risk here is mitigated due to the fact that Nextcloud employs a strict Content-Security-Policy disallowing execution of arbitrary JavaScript. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | 20.0.13; 21.0.0 to before 21.0.5; before 22.2.0 | 21.0.5, 22.2.0 | Patch available | CNA |
- security-advisories Vendornextcloud Affected 20.0.13; 21.0.0 to before 21.0.5; before 22.2.0 Fixed in 21.0.5, 22.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:server:*:*:*:*:*:*:*:* | 20.0.3 to before 20.0.13; 21.0.1 to before 21.0.5; 22.1.1 to before 22.2.0 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:server:*:*:*:*:*:*:*:* Versions 20.0.3 to before 20.0.13; 21.0.1 to before 21.0.5; 22.1.1 to before 22.2.0 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 21.0.5, 22.2.0
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41178
References
More nextcloud Server vulnerabilities
- TI-2021-18018 Two-Factor Authentication not enforced for pages marked as public CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-41178 · CVE Program
- CVE-2021-41178 · NVD
- FIRST EPSS
- CVE-2021-41178 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences