Two-Factor Authentication not enforced for pages marked as public
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Nextcloud is an open-source, self-hosted productivity platform. Prior to Nextcloud Server versions 20.0.13, 21.0.5, and 22.2.0, the Two-Factor Authentication wasn't enforced for pages marked as public. Any page marked as `@PublicPage` could thus be accessed with a valid user session that isn't authenticated. This particularly affects the Nextcloud Talk application, as this could be leveraged to gain access to any private chat channel without going through the Two-Factor flow. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | before 20.0.13; 21.0.0 to before 21.0.5; before 22.2.0 | 20.0.13, 21.0.5, 22.2.0 | Patch available | CNA |
- security-advisories Vendornextcloud Affected before 20.0.13; 21.0.0 to before 21.0.5; before 22.2.0 Fixed in 20.0.13, 21.0.5, 22.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:server:*:*:*:*:*:*:*:* | 20.0.3 to before 20.0.13; 21.0.1 to before 21.0.5; 22.1.1 to before 22.2.0 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:server:*:*:*:*:*:*:*:* Versions 20.0.3 to before 20.0.13; 21.0.1 to before 21.0.5; 22.1.1 to before 22.2.0 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 20.0.13, 21.0.5, 22.2.0
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41179
References
More nextcloud Server vulnerabilities
- TI-2021-18017 File Traversal affecting SVG files on Nextcloud Server CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41179 · CVE Program
- CVE-2021-41179 · NVD
- FIRST EPSS
- CVE-2021-41179 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences