Cookie persistence in Symfony
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
Symfony/SecurityBundle is the security system for Symfony, a PHP framework for web and console applications and a set of reusable PHP components. Since the rework of the Remember me cookie in version 5.3.0, the cookie is not invalidated when the user changes their password. Attackers can therefore maintain their access to the account even if the password is changed as long as they have had the chance to login once and get a valid remember me cookie. Starting with version 5.3.12, Symfony makes the password part of the signature by default. In that way, when the password changes, then the cookie is not valid anymore.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 5.3.0 to before 5.3.12 | 5.3.12 | Patch available | CNA |
| — | symfony/security-bundle (Packagist) | 5.3.0 to before 5.3.12 | 5.3.12 | Patch available | GHSA-qw36-p97w-vcqr |
| — | symfony/symfony (Packagist) | 5.3.0 to before 5.3.12 | 5.3.12 | Patch available | GHSA-qw36-p97w-vcqr |
- symfony Vendorsymfony Affected 5.3.0 to before 5.3.12 Fixed in 5.3.12 Patch available CNA
- symfony/security-bundle (Packagist) Vendor— Affected 5.3.0 to before 5.3.12 Fixed in 5.3.12 Patch available GHSA-qw36-p97w-vcqr
- symfony/symfony (Packagist) Vendor— Affected 5.3.0 to before 5.3.12 Fixed in 5.3.12 Patch available GHSA-qw36-p97w-vcqr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 5.3.0 to before 5.3.12 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 5.3.0 to before 5.3.12 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 5.3.12
- Fix · GHSA-qw36-p97w-vcqr symfony/security-bundle (Packagist) Fixed in 5.3.12 Advisory →
- Fix · GHSA-qw36-p97w-vcqr symfony/symfony (Packagist) Fixed in 5.3.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41268
- 2026-10-03 Alias added: GHSA-qw36-p97w-vcqr
References
Patch 3
Advisory 2
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2021-41268 · CVE Program
- CVE-2021-41268 · NVD
- FIRST EPSS
- GHSA-qw36-p97w-vcqr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences