Improper input validation in symfony
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 5.4.46 until 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the CVE-2024-50340 fix gated runtime argv parsing on empty($_GET), but parse_str() and the web SAPI can disagree, allowing a crafted query string to leave $_GET empty while $_SERVER['argv'] still carries attacker-controlled --env or --no-debug flags that change APP_ENV or APP_DEBUG. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 5.4.46 to before 5.4.52; 6.4.14 to before 6.4.40; 7.1.7 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 | 5.4.52, 6.4.40, 7.4.12, 8.0.12 | Patch available | CNA |
| symfony | runtime | 5.4.46 to before 5.4.52; 6.4.14 to before 6.4.40; 7.1.7 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 | 5.4.52, 6.4.40, 7.4.12, 8.0.12 | Patch available | CNA |
| — | symfony/runtime (Packagist) | 5.4.46 to before 5.4.52 | 5.4.52 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/runtime (Packagist) | 6.4.14 to before 6.4.40 | 6.4.40 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/runtime (Packagist) | 7.1.7 to before 7.4.12 | 7.4.12 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/runtime (Packagist) | 8.0.0 to before 8.0.12 | 8.0.12 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/symfony (Packagist) | 5.4.46 to before 5.4.52 | 5.4.52 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/symfony (Packagist) | 6.4.14 to before 6.4.40 | 6.4.40 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/symfony (Packagist) | 7.1.7 to before 7.4.12 | 7.4.12 | Patch available | GHSA-fqc7-9xjw-jrh3 |
| — | symfony/symfony (Packagist) | 8.0.0 to before 8.0.12 | 8.0.12 | Patch available | GHSA-fqc7-9xjw-jrh3 |
- symfony Vendorsymfony Affected 5.4.46 to before 5.4.52; 6.4.14 to before 6.4.40; 7.1.7 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12 Patch available CNA
- runtime Vendorsymfony Affected 5.4.46 to before 5.4.52; 6.4.14 to before 6.4.40; 7.1.7 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12 Patch available CNA
- symfony/runtime (Packagist) Vendor— Affected 5.4.46 to before 5.4.52 Fixed in 5.4.52 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/runtime (Packagist) Vendor— Affected 6.4.14 to before 6.4.40 Fixed in 6.4.40 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/runtime (Packagist) Vendor— Affected 7.1.7 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/runtime (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/symfony (Packagist) Vendor— Affected 5.4.46 to before 5.4.52 Fixed in 5.4.52 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/symfony (Packagist) Vendor— Affected 6.4.14 to before 6.4.40 Fixed in 6.4.40 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/symfony (Packagist) Vendor— Affected 7.1.7 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-fqc7-9xjw-jrh3
- symfony/symfony (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-fqc7-9xjw-jrh3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 5.4.46 to before 5.4.52; 6.4.14 to before 6.4.40; 7.1.7 to before 7.4.12; 8.0.0 to before 8.0.12 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 5.4.46 to before 5.4.52; 6.4.14 to before 6.4.40; 7.1.7 to before 7.4.12; 8.0.0 to before 8.0.12 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Fix · CNA runtime (symfony) Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/runtime (Packagist) Fixed in 5.4.52 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/runtime (Packagist) Fixed in 6.4.40 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/runtime (Packagist) Fixed in 7.4.12 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/runtime (Packagist) Fixed in 8.0.12 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/symfony (Packagist) Fixed in 5.4.52 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/symfony (Packagist) Fixed in 6.4.40 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/symfony (Packagist) Fixed in 7.4.12 Advisory →
- Fix · GHSA-fqc7-9xjw-jrh3 symfony/symfony (Packagist) Fixed in 8.0.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-47767
- 2026-10-03 Alias added: GHSA-fqc7-9xjw-jrh3
References
Other 6
- https://github.com/symfony/symfony/security/advisories/GHSA-fqc7-9xjw-jrh3
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-33105 Symfony: YAML Parser ReDoS via Catastrophic Backtracking in Parser::cleanup() Regex CVSS 4.0HIGH 8.7
Sources
- CVE-2026-47767 · CVE Program
- CVE-2026-47767 · NVD
- FIRST EPSS
- GHSA-fqc7-9xjw-jrh3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences