Read the docs
TI-2021-18312 Aliases CVE-2021-41580GHSA-f794-r6xc-hf3v

The passport-oauth2 package before 1.6.1 for Node.js mishandles the error condition of…

Priority LOW 27CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

The passport-oauth2 package before 1.6.1 for Node.js mishandles the error condition of failure to obtain an access token. This is exploitable in certain use cases where an OAuth identity provider uses an HTTP 200 status code for authentication-failure error reports, and an application grants authorization upon simply receiving the access token (i.e., does not try to use the token). NOTE: the passport-oauth2 vendor does not consider this a passport-oauth2 vulnerability

Why it matters now

EPSS 0.01303 70th percentileScored 2026-11-07
Fix Fixed passport-oauth2 (npm): 1.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—passport-oauth2 (npm)before 1.6.11.6.1Patch availableGHSA-f794-r6xc-hf3v
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • passport-oauth2 (npm) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-f794-r6xc-hf3v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:passportjs:passport-oauth2:*:*:*:*:*:node.js:*:*before 1.6.1VulnerablePassportjs
  • cpe:2.3:a:passportjs:passport-oauth2:*:*:*:*:*:node.js:*:* Versions before 1.6.1 Vulnerable ·Passportjs

Remediation

  • Fix · GHSA-f794-r6xc-hf3v passport-oauth2 (npm) Fixed in 1.6.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41580
  2. 2026-10-03 Alias added: GHSA-f794-r6xc-hf3v

References

Sources