Read the docs
TI-2021-18620 Aliases CVE-2021-42112GHSA-h9ph-jcgh-gf69

The "File upload question" functionality in LimeSurvey 3.x-LTS through 3.27.18 allows XSS…

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The "File upload question" functionality in LimeSurvey 3.x-LTS through 3.27.18 allows XSS in assets/scripts/modaldialog.js and assets/scripts/uploader.js.

Why it matters now

EPSS 0.0153 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed limesurvey/limesurvey (Packagist): 3.27.19

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—limesurvey/limesurvey (Packagist)before 3.27.193.27.19Patch availableGHSA-h9ph-jcgh-gf69
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • limesurvey/limesurvey (Packagist) Vendor— Affected before 3.27.19 Fixed in 3.27.19 Patch available GHSA-h9ph-jcgh-gf69

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:*3.0.0 – 3.27.18VulnerableLimeSurvey
  • cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* Versions 3.0.0 – 3.27.18 Vulnerable ·LimeSurvey

Remediation

  • Fix · GHSA-h9ph-jcgh-gf69 limesurvey/limesurvey (Packagist) Fixed in 3.27.19 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-42112
  2. 2026-10-03 Alias added: GHSA-h9ph-jcgh-gf69

References

  • TI-2020-09194 LimeSurvey before 4.1.12+200324 contains a path traversal vulnerability in… CVSS 3.1CRITICAL 9.8
  • TI-2024-28662 An issue in the js_localize.php function of LimeSurvey v6.6.2 and before allows attackers… CVSS 3.1HIGH 8.8
  • TI-2024-26167 Lime Survey <= 6.5.12 is vulnerable to Cross Site Request Forgery (CSRF). CVSS 3.1HIGH 8.8
  • TI-2022-21122 LimeSurvey before v5.0.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1HIGH 7.2
  • TI-2007-03523 Multiple PHP remote file inclusion vulnerabilities in LimeSurvey (aka PHPSurveyor)… CVSS 2.0MEDIUM 6.8
  • TI-2018-12189 An issue was discovered in TCPDF before 6.2.22. CVSS 3.0CRITICAL 9.8
See all 81 →

Sources