reflected XSS in search functionality of WP Cloud Plugins - Out-of-the-Box
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Insufficient Input Validation in the search functionality of Wordpress plugin Out-of-the-Box prior to 1.20.3 allows unauthenticated user to craft a reflected Cross-Site Scripting attack.
Why it matters now
EPSS 0.00753 55th percentileScored 2026-11-07
Fix Fixed Out-of-the-Box (WP Cloud Plugins): 1.20.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WP Cloud Plugins | Out-of-the-Box | before 1.20.3 | 1.20.3 | Patch available | CNA |
- Out-of-the-Box VendorWP Cloud Plugins Affected before 1.20.3 Fixed in 1.20.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpcloudplugins:out-of-the-box:*:*:*:*:*:wordpress:*:* | before 1.20.3 | Vulnerable | WP Cloud Plugins |
- cpe:2.3:a:wpcloudplugins:out-of-the-box:*:*:*:*:*:wordpress:*:* Versions before 1.20.3 Vulnerable ·WP Cloud Plugins
Remediation
- Fix · CNA Out-of-the-Box (WP Cloud Plugins) Fixed in 1.20.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-42547
- 2026-10-03 Alias added: GHSA-823p-4g73-2fv5
References
Sources
- CVE-2021-42547 · CVE Program
- CVE-2021-42547 · NVD
- FIRST EPSS
- GHSA-823p-4g73-2fv5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences