Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.
Why it matters now
EPSS 0.00869 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed code-server (npm): 3.12.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | code-server (npm) | before 3.12.0 | 3.12.0 | Patch available | GHSA-2gp3-6c9p-jp7w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- code-server (npm) Vendor— Affected before 3.12.0 Fixed in 3.12.0 Patch available GHSA-2gp3-6c9p-jp7w
Remediation
- Fix · GHSA-2gp3-6c9p-jp7w code-server (npm) Fixed in 3.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-42648
- 2026-10-03 Alias added: GHSA-2gp3-6c9p-jp7w
References
More coder Code-server vulnerabilities
- TI-2023-11339 Origin validation error in code-server CVSS 3.1CRITICAL 9.3
- TI-2021-02741 Inefficient Regular Expression Complexity in cdr/code-server CVSS 3.1HIGH 7.5
Sources
- CVE-2021-42648 · CVE Program
- CVE-2021-42648 · NVD
- FIRST EPSS
- GHSA-2gp3-6c9p-jp7w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences