Read the docs
TI-2023-11339 Aliases CVE-2023-26114GHSA-frjg-g767-7363

Origin validation error in code-server

Priority MEDIUM 42CWE-1385Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-346.

Summary

Versions of the package code-server before 4.10.1 are vulnerable to Missing Origin Validation in WebSockets handshakes. Exploiting this vulnerability can allow an adversary in specific scenarios to access data from and connect to the code-server instance.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0034 27th percentileScored 2026-11-07
Fix Fixed code-server: 4.10.1code-server (npm): 4.10.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—code-serverbefore 4.10.14.10.1Patch availableCNA
—code-server (npm)before 4.10.14.10.1Patch availableGHSA-frjg-g767-7363
  • code-server Vendor— Affected before 4.10.1 Fixed in 4.10.1 Patch available CNA
  • code-server (npm) Vendor— Affected before 4.10.1 Fixed in 4.10.1 Patch available GHSA-frjg-g767-7363

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:coder:code-server:*:*:*:*:*:*:*:*before 4.10.1Vulnerablecoder
  • cpe:2.3:a:coder:code-server:*:*:*:*:*:*:*:* Versions before 4.10.1 Vulnerable ·coder

Remediation

  • Fix · CNA code-server Fixed in 4.10.1
  • Fix · GHSA-frjg-g767-7363 code-server (npm) Fixed in 4.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-26114
  2. 2026-10-03 Alias added: GHSA-frjg-g767-7363

References

  • TI-2021-02741 Inefficient Regular Expression Complexity in cdr/code-server CVSS 3.1HIGH 7.5
  • TI-2021-18883 Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0… CVSS 3.1MEDIUM 6.1

Sources