Dubbo Hessian cause RCE when parse error
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
A deserialization vulnerability existed in dubbo hessian-lite 3.2.11 and its earlier versions, which could lead to malicious code execution. Most Dubbo users use Hessian2 as the default serialization/deserialization protocol, during Hessian catch unexpected exceptions, Hessian will log out some imformation for users, which may cause remote command execution. This issue affects Apache Dubbo Apache Dubbo 2.6.x versions prior to 2.6.12; Apache Dubbo 2.7.x versions prior to 2.7.15; Apache Dubbo 3.0.x versions prior to 3.0.5.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Dubbo | Apache Dubbo 2.6.x to before 2.6.12; Apache Dubbo 2.7.x to before 2.7.15; Apache Dubbo 3.0.x to before 3.0.5 | 2.6.12, 2.7.15, 3.0.5 | Patch available | CNA |
| — | org.apache.dubbo:dubbo (Maven) | 2.6.0 to before 2.6.12 | 2.6.12 | Patch available | GHSA-vp5x-3v8r-qprw |
| — | org.apache.dubbo:dubbo (Maven) | 2.7.0 to before 2.7.15 | 2.7.15 | Patch available | GHSA-vp5x-3v8r-qprw |
| — | org.apache.dubbo:dubbo (Maven) | 3.0.0 to before 3.0.5 | 3.0.5 | Patch available | GHSA-vp5x-3v8r-qprw |
- Apache Dubbo VendorApache Affected Apache Dubbo 2.6.x to before 2.6.12; Apache Dubbo 2.7.x to before 2.7.15; Apache Dubbo 3.0.x to before 3.0.5 Fixed in 2.6.12, 2.7.15, 3.0.5 Patch available CNA
- org.apache.dubbo:dubbo (Maven) Vendor— Affected 2.6.0 to before 2.6.12 Fixed in 2.6.12 Patch available GHSA-vp5x-3v8r-qprw
- org.apache.dubbo:dubbo (Maven) Vendor— Affected 2.7.0 to before 2.7.15 Fixed in 2.7.15 Patch available GHSA-vp5x-3v8r-qprw
- org.apache.dubbo:dubbo (Maven) Vendor— Affected 3.0.0 to before 3.0.5 Fixed in 3.0.5 Patch available GHSA-vp5x-3v8r-qprw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:dubbo:*:*:*:*:*:*:*:* | 2.6.0 to before 2.6.12; 2.7.0 to before 2.7.15; 3.0.0 to before 3.0.5 | Vulnerable | Apache |
- cpe:2.3:a:apache:dubbo:*:*:*:*:*:*:*:* Versions 2.6.0 to before 2.6.12; 2.7.0 to before 2.7.15; 3.0.0 to before 3.0.5 Vulnerable ·Apache
Remediation
- Fix · CNA Apache Dubbo (Apache Software Foundation) Fixed in 2.6.12, 2.7.15, 3.0.5
- Fix · GHSA-vp5x-3v8r-qprw org.apache.dubbo:dubbo (Maven) Fixed in 2.6.12 Advisory →
- Fix · GHSA-vp5x-3v8r-qprw org.apache.dubbo:dubbo (Maven) Fixed in 2.7.15 Advisory →
- Fix · GHSA-vp5x-3v8r-qprw org.apache.dubbo:dubbo (Maven) Fixed in 3.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43297
- 2026-10-03 Alias added: GHSA-vp5x-3v8r-qprw
References
More Apache Dubbo vulnerabilities
- TI-2021-12489 Regular expression Denial of Service in MooTools CVSS 3.1CRITICAL 9.8
- TI-2021-10721 Apache Dubbo RCE on customers via Script route poisoning (Nashorn script injection) CVSS 3.1CRITICAL 9.8
- TI-2021-10720 Apache Dubbo RCE on customers via Condition route poisoning (Unsafe YAML unmarshaling) CVSS 3.1CRITICAL 9.8
- TI-2019-13107 Deserialization of untrusted data in Apache Dubbo CVSS 3.1CRITICAL 9.8
- TI-2021-07774 Dubbo Zookeeper does not check serialization id CVSS 3.1CRITICAL 9.8
- TI-2020-01872 Deserialization of untrusted data in Apache Dubbo CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-43297 · CVE Program
- CVE-2021-43297 · NVD
- FIRST EPSS
- GHSA-vp5x-3v8r-qprw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences