Incorrect authorization in moodle
Priority LOW 26CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863, CWE-668 and the CVSS impact.
Summary
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.
Why it matters now
EPSS 0.01126 66th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.11, 3.10.8, 3.11.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | moodle 3.11.4, moodle 3.10.8 and moodle 3.9.11 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.11 | 3.9.11 | Patch available | GHSA-g39c-mccf-rxjv |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.8 | 3.10.8 | Patch available | GHSA-g39c-mccf-rxjv |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.4 | 3.11.4 | Patch available | GHSA-g39c-mccf-rxjv |
- moodle Vendor— Affected moodle 3.11.4, moodle 3.10.8 and moodle 3.9.11 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.11 Fixed in 3.9.11 Patch available GHSA-g39c-mccf-rxjv
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.8 Fixed in 3.10.8 Patch available GHSA-g39c-mccf-rxjv
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.4 Fixed in 3.11.4 Patch available GHSA-g39c-mccf-rxjv
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 3.8.8; 3.9.0 to before 3.9.11; 3.10.0 to before 3.10.8; 3.11.0 to before 3.11.4 | Vulnerable | Moodle |
| cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.8.8; 3.9.0 to before 3.9.11; 3.10.0 to before 3.10.8; 3.11.0 to before 3.11.4 Vulnerable ·Moodle
- cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-g39c-mccf-rxjv moodle/moodle (Packagist) Fixed in 3.9.11 Advisory →
- Fix · GHSA-g39c-mccf-rxjv moodle/moodle (Packagist) Fixed in 3.10.8 Advisory →
- Fix · GHSA-g39c-mccf-rxjv moodle/moodle (Packagist) Fixed in 3.11.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43560
- 2026-10-03 Alias added: GHSA-g39c-mccf-rxjv
References
Sources
- CVE-2021-43560 · CVE Program
- CVE-2021-43560 · NVD
- FIRST EPSS
- GHSA-g39c-mccf-rxjv · GitHub Advisory Database · CC BY 4.0
- CVE-2021-43560 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences