A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.1.0.
Priority LOW 36CWE-476Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-476.
Summary
A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.1.0. This bug can be leveraged by constructing a message whose payload is nil and sending this message with the method 'forwardToLeader'. This bug has been admitted and fixed by the developers of Fabric. If leveraged, any leader node will crash.
Why it matters now
EPSS 0.01336 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/hyperledger/fabric (Go): 2.3.3, 2.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/hyperledger/fabric (Go) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-vjj6-5m9f-wqjw |
| — | github.com/hyperledger/fabric (Go) | before 2.2.4 | 2.2.4 | Patch available | GHSA-vjj6-5m9f-wqjw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/hyperledger/fabric (Go) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-vjj6-5m9f-wqjw
- github.com/hyperledger/fabric (Go) Vendor— Affected before 2.2.4 Fixed in 2.2.4 Patch available GHSA-vjj6-5m9f-wqjw
Remediation
- Fix · GHSA-vjj6-5m9f-wqjw github.com/hyperledger/fabric (Go) Fixed in 2.3.3 Advisory →
- Fix · GHSA-vjj6-5m9f-wqjw github.com/hyperledger/fabric (Go) Fixed in 2.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43667
- 2026-10-03 Alias added: GHSA-vjj6-5m9f-wqjw
References
More backstage Fabric vulnerabilities
- TI-2021-19508 A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0. CVSS 3.1HIGH 7.5
Sources
- CVE-2021-43667 · CVE Program
- CVE-2021-43667 · NVD
- FIRST EPSS
- GHSA-vjj6-5m9f-wqjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences