A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0.
Priority LOW 35CWE-444Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0. It can easily break down as many orderers as the attacker wants. This bug can be leveraged by constructing a message whose header is invalid to the interface Order. This bug has been admitted and fixed by the developers of Fabric.
Why it matters now
EPSS 0.01127 66th percentileScored 2026-11-07
Fix Fixed github.com/hyperledger/fabric (Go): 2.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/hyperledger/fabric (Go) | before 2.4.0 | 2.4.0 | Patch available | GHSA-j96p-r523-8r3w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/hyperledger/fabric (Go) Vendor— Affected before 2.4.0 Fixed in 2.4.0 Patch available GHSA-j96p-r523-8r3w
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linuxfoundation:fabric:1.4.0:*:*:*:*:*:*:* | 1.4.0 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:fabric:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:fabric:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | backstage |
| cpe:2.3:a:linuxfoundation:fabric:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | backstage |
- cpe:2.3:a:linuxfoundation:fabric:1.4.0:*:*:*:*:*:*:* Versions 1.4.0 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:fabric:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:fabric:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·backstage
- cpe:2.3:a:linuxfoundation:fabric:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·backstage
Remediation
- Fix · GHSA-j96p-r523-8r3w github.com/hyperledger/fabric (Go) Fixed in 2.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43669
- 2026-10-03 Alias added: GHSA-j96p-r523-8r3w
References
More backstage Fabric vulnerabilities
- TI-2021-19506 A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.1.0. CVSS 3.1HIGH 7.5
Sources
- CVE-2021-43669 · CVE Program
- CVE-2021-43669 · NVD
- FIRST EPSS
- GHSA-j96p-r523-8r3w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences