An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in…
Priority MEDIUM 45CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
Why it matters now
EPSS 0.01294 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed edu.stanford.nlp:stanford-corenlp (Maven): 4.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | edu.stanford.nlp:stanford-corenlp (Maven) | before 4.4.0 | 4.4.0 | Patch available | GHSA-x2p8-rgfm-qw3v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- edu.stanford.nlp:stanford-corenlp (Maven) Vendor— Affected before 4.4.0 Fixed in 4.4.0 Patch available GHSA-x2p8-rgfm-qw3v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:stanford:corenlp:4.3.2:*:*:*:*:*:*:* | 4.3.2 | Vulnerable | stanfordnlp |
- cpe:2.3:a:stanford:corenlp:4.3.2:*:*:*:*:*:*:* Versions 4.3.2 Vulnerable ·stanfordnlp
Remediation
- Fix · GHSA-x2p8-rgfm-qw3v edu.stanford.nlp:stanford-corenlp (Maven) Fixed in 4.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-44550
- 2026-10-03 Alias added: GHSA-x2p8-rgfm-qw3v
References
More stanfordnlp Corenlp vulnerabilities
- TI-2022-00175 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1CRITICAL 9.8
- TI-2021-02801 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1CRITICAL 9.8
- TI-2021-02797 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1HIGH 7.5
- TI-2022-00136 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1HIGH 7.1
Sources
- CVE-2021-44550 · CVE Program
- CVE-2021-44550 · NVD
- FIRST EPSS
- GHSA-x2p8-rgfm-qw3v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences