Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp
Priority LOW 33CWE-611Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
Why it matters now
EPSS 0.00763 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed stanfordnlp/corenlp (stanfordnlp): 4.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| stanfordnlp | stanfordnlp/corenlp | before 4.3.3 | 4.3.3 | Patch available | CNA |
| — | edu.stanford.nlp:stanford-corenlp (Maven) | up to 4.3.2 | — | No fix listed | GHSA-mh83-jcw5-rjh8 |
- stanfordnlp/corenlp Vendorstanfordnlp Affected before 4.3.3 Fixed in 4.3.3 Patch available CNA
- edu.stanford.nlp:stanford-corenlp (Maven) Vendor— Affected up to 4.3.2 Fixed in — No fix listed GHSA-mh83-jcw5-rjh8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:stanford:corenlp:*:*:*:*:*:*:*:* | up to 4.3.2 | Vulnerable | stanfordnlp |
- cpe:2.3:a:stanford:corenlp:*:*:*:*:*:*:*:* Versions up to 4.3.2 Vulnerable ·stanfordnlp
Remediation
- Fix · CNA stanfordnlp/corenlp (stanfordnlp) Fixed in 4.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0198
- 2026-10-03 Alias added: GHSA-mh83-jcw5-rjh8
References
More stanfordnlp Corenlp vulnerabilities
- TI-2022-00175 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1CRITICAL 9.8
- TI-2021-02801 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1CRITICAL 9.8
- TI-2021-20146 An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in… CVSS 3.1CRITICAL 9.8
- TI-2021-02797 Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0198 · CVE Program
- CVE-2022-0198 · NVD
- FIRST EPSS
- GHSA-mh83-jcw5-rjh8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences