Django CMS 3.7.3 does not validate the plugin_type parameter while generating error…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.
Why it matters now
EPSS 0.00638 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed django-cms (PyPI): 3.7.4, 3.6.1, 3.5.4 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | django-cms (PyPI) | 3.7.0 to before 3.7.4 | 3.7.4 | Patch available | GHSA-hx7c-qpfq-xcrp |
| — | django-cms (PyPI) | 3.6.0 to before 3.6.1 | 3.6.1 | Patch available | GHSA-hx7c-qpfq-xcrp |
| — | django-cms (PyPI) | 3.5.0 to before 3.5.4 | 3.5.4 | Patch available | GHSA-hx7c-qpfq-xcrp |
| — | django-cms (PyPI) | 3.4.0 to before 3.4.7 | 3.4.7 | Patch available | GHSA-hx7c-qpfq-xcrp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- django-cms (PyPI) Vendor— Affected 3.7.0 to before 3.7.4 Fixed in 3.7.4 Patch available GHSA-hx7c-qpfq-xcrp
- django-cms (PyPI) Vendor— Affected 3.6.0 to before 3.6.1 Fixed in 3.6.1 Patch available GHSA-hx7c-qpfq-xcrp
- django-cms (PyPI) Vendor— Affected 3.5.0 to before 3.5.4 Fixed in 3.5.4 Patch available GHSA-hx7c-qpfq-xcrp
- django-cms (PyPI) Vendor— Affected 3.4.0 to before 3.4.7 Fixed in 3.4.7 Patch available GHSA-hx7c-qpfq-xcrp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django-cms:django_cms:*:*:*:*:*:*:*:* | 3.4.0 to before 3.4.7; 3.5.0 to before 3.5.4; 3.6.0 to before 3.6.1; 3.7.0 to before 3.7.4 | Vulnerable | django-cms |
- cpe:2.3:a:django-cms:django_cms:*:*:*:*:*:*:*:* Versions 3.4.0 to before 3.4.7; 3.5.0 to before 3.5.4; 3.6.0 to before 3.6.1; 3.7.0 to before 3.7.4 Vulnerable ·django-cms
Remediation
- Fix · GHSA-hx7c-qpfq-xcrp django-cms (PyPI) Fixed in 3.7.4 Advisory →
- Fix · GHSA-hx7c-qpfq-xcrp django-cms (PyPI) Fixed in 3.6.1 Advisory →
- Fix · GHSA-hx7c-qpfq-xcrp django-cms (PyPI) Fixed in 3.5.4 Advisory →
- Fix · GHSA-hx7c-qpfq-xcrp django-cms (PyPI) Fixed in 3.4.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-44649
- 2026-10-03 Alias added: GHSA-hx7c-qpfq-xcrp
- 2026-11-05 EPSS moved to the 50th–90th percentile
References
Advisory 3
More django-cms Django Cms vulnerabilities
- TI-2024-10485 Stored XSS in Open Source Project "django-cms" CVSS 3.1MEDIUM 4.8
- TI-2015-04262 Cross-site request forgery (CSRF) vulnerability in django CMS before 3.0.14, 3.1.x before… CVSS 3.0HIGH 8.8
Sources
- CVE-2021-44649 · CVE Program
- CVE-2021-44649 · NVD
- FIRST EPSS
- GHSA-hx7c-qpfq-xcrp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences