Authenticated Remote Code Execution in OpenLiteSpeed Web Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Improper Input Validation vulnerability in LiteSpeed Technologies OpenLiteSpeed Web Server and LiteSpeed Web Server dashboards allows Command Injection. This affects 1.7.0 versions before 1.7.16.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| LiteSpeed Technologies | OpenLiteSpeed Web Server | 1.7.0 to before 1.7.16.1 | 1.7.16.1 | Patch available | CNA |
| LiteSpeed Technologies | LiteSpeed Web Server | 1.7.0 to before 1.7.16.1 | 1.7.16.1 | Patch available | CNA |
- OpenLiteSpeed Web Server VendorLiteSpeed Technologies Affected 1.7.0 to before 1.7.16.1 Fixed in 1.7.16.1 Patch available CNA
- LiteSpeed Web Server VendorLiteSpeed Technologies Affected 1.7.0 to before 1.7.16.1 Fixed in 1.7.16.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:litespeedtech:openlitespeed:*:*:*:*:*:*:*:* | 1.7.0 – 1.7.16.1 | Vulnerable | litespeedtech |
- cpe:2.3:a:litespeedtech:openlitespeed:*:*:*:*:*:*:*:* Versions 1.7.0 – 1.7.16.1 Vulnerable ·litespeedtech
Remediation
- Fix · CNA OpenLiteSpeed Web Server (LiteSpeed Technologies) Fixed in 1.7.16.1
- Fix · CNA LiteSpeed Web Server (LiteSpeed Technologies) Fixed in 1.7.16.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
LiteSpeed Web Server, OpenLiteSpeed Web Server 1.7.16.1
3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-00031 Privilege Escalation in OpenLiteSpeed Web ServerPriority MEDIUM 41
- TI-2022-00029 Directory Traversal in OpenLiteSpeed Web ServerPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0073
- 2026-10-03 Alias added: GHSA-p42f-x6hp-xv84
References
More LiteSpeed Technologies vulnerabilities
- TI-2026-35606 LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to… KEVCVSS 4.0CRITICAL 10.0
- TI-2026-39296 LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before… KEVCVSS 3.1HIGH 8.5
- TI-2024-29589 WordPress LiteSpeed Cache plugin < 6.5.0.1 - Unauthenticated Account Takeover via Cookie Leak vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-18601 WordPress LiteSpeed Cache plugin <= 6.3.0.1 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-22517 LiteSpeed Web Server Enterprise 5.4.11 - Command Injection CVSS 4.0HIGH 8.6
- TI-2023-20892 WordPress LiteSpeed Cache plugin <= 5.7 - Unauthenticated Site Wide Stored XSS vulnerability CVSS 3.1HIGH 8.3
Sources
- CVE-2022-0073 · CVE Program
- CVE-2022-0073 · NVD
- FIRST EPSS
- GHSA-p42f-x6hp-xv84 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences