XootiX Plugins <= Various Versions Cross-Site Request Forgery to Arbitrary Options Update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Login/Signup Popup, Waitlist Woocommerce ( Back in stock notifier ), and Side Cart Woocommerce (Ajax) WordPress plugins by XootiX are vulnerable to Cross-Site Request Forgery via the save_settings function found in the ~/includes/xoo-framework/admin/class-xoo-admin-settings.php file which makes it possible for attackers to update arbitrary options on a site that can be used to create an administrative user account and grant full privileged access to a compromised site. This affects versions <= 2.2 in Login/Signup Popup, versions <= 2.5.1 in Waitlist Woocommerce ( Back in stock notifier ), and versions <= 2.0 in Side Cart Woocommerce (Ajax).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| xootix | Login/Signup Popup | 2.2 – 2.2 | — | No fix listed | CNA |
| xootix | Waitlist Woocommerce ( Back in stock notifier ) | 2.5.1 – 2.5.1 | — | No fix listed | CNA |
| xootix | Side Cart Woocommerce (Ajax) | 2.0 – 2.0 | — | No fix listed | CNA |
- Login/Signup Popup Vendorxootix Affected 2.2 – 2.2 Fixed in — No fix listed CNA
- Waitlist Woocommerce ( Back in stock notifier ) Vendorxootix Affected 2.5.1 – 2.5.1 Fixed in — No fix listed CNA
- Side Cart Woocommerce (Ajax) Vendorxootix Affected 2.0 – 2.0 Fixed in — No fix listed CNA
CPE configurations NVD · 3
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0215
- 2026-10-03 Alias added: GHSA-824x-r58x-c6fc
References
Exploit 5
- https://www.wordfence.com/blog/2022/01/84000-wordpress-sites-affected-by-three-plugins-with-the-same-vulnerability/
- https://wordfence.com/vulnerability-advisories/#CVE-2022-0215
- https://plugins.trac.wordpress.org/browser/easy-login-woocommerce/tags/2.2/includes/xoo-framework/admin/class-xoo-admin-settings.php#L122
- https://plugins.trac.wordpress.org/browser/waitlist-woocommerce/tags/2.5.1/includes/xoo-framework/admin/class-xoo-admin-settings.php#L122
- https://plugins.trac.wordpress.org/browser/side-cart-woocommerce/tags/2.1/includes/xoo-framework/admin/class-xoo-admin-settings.php?rev=2538194#L128
More xootix Login/signup Popup vulnerabilities
- TI-2024-04943 XootiX Framework <= Various Plugin Versions - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2020-18886 Login/Signup Popup < 1.5 - Missing Authorization CVSS 3.1HIGH 7.4
- TI-2025-00903 Cross-site scripting in xootix Login & Register Customizer – Popup | Slider | Inline |… CVSS 3.1MEDIUM 6.4
- TI-2024-05260 Login/Signup Popup ( Inline Form + Woocommerce ) 2.7.1 - 2.7.2 - Missing Authorization to Arbitrary Options Exposure CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-0215 · CVE Program
- CVE-2022-0215 · NVD
- FIRST EPSS
- GHSA-824x-r58x-c6fc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences