XML external entity injection in prosody
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-611 and the CVSS impact.
Summary
It was discovered that an internal Prosody library to load XML based on libexpat does not properly restrict the XML features allowed in parsed XML data. Given suitable attacker input, this results in expansion of recursive entity references from DTDs (CWE-776). In addition, depending on the libexpat version used, it may also allow injections using XML External Entity References (CWE-611).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | prosody | Fixed in prosody 0.11.12, Affects all versions with support for WebSockets. | — | No fix listed | CNA |
- prosody Vendor— Affected Fixed in prosody 0.11.12, Affects all versions with support for WebSockets. Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0217
References
More Prosody vulnerabilities
- TI-2018-07663 Improper authentication in [UNKNOWN] prosody CVSS 3.0HIGH 8.8
- TI-2014-02196 Prosody before 0.9.4 does not properly restrict the processing of compressed XML… CVSS 2.0HIGH 7.8
- TI-2014-02195 plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome… CVSS 2.0HIGH 7.8
- TI-2026-31684 Resource allocation without limits in Prosody CVSS 3.1HIGH 7.5
- TI-2026-31683 Memory leak in Prosody CVSS 3.1HIGH 7.5
- TI-2021-15483 muc.lib.lua in Prosody 0.11.0 through 0.11.9 allows remote attackers to obtain sensitive… CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0217 · CVE Program
- CVE-2022-0217 · NVD
- FIRST EPSS
- CVE-2022-0217 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences