Memory leak in Prosody
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-401.
Summary
An issue was discovered in Prosody before 0.12.6 and 1.0.0 through 13.0.0 before 13.0.5. A Denial of Service can occur via memory exhaustion caused by memory leaks from unauthenticated connections.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Prosody (Prosody) Fixed in 0.12.6, 13.0.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Prosody 0.12.6, 13.0.5
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-31684 Resource allocation without limits in ProsodyPriority LOW 39
- TI-2026-31682 An issue was discovered in Prosody before 0.12.6 and 1.0.0 through 13.0.0 before 13.0.5…Priority LOW 34
- TI-2026-31681 Incorrect authorization in ProsodyPriority LOW 34
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-43506
- 2026-10-03 Alias added: GHSA-q553-9xvw-ww8h
References
More Prosody vulnerabilities
- TI-2022-00154 XML external entity injection in prosody CVSS 3.1HIGH 7.5
- TI-2018-07663 Improper authentication in [UNKNOWN] prosody CVSS 3.0HIGH 8.8
- TI-2014-02196 Prosody before 0.9.4 does not properly restrict the processing of compressed XML… CVSS 2.0HIGH 7.8
- TI-2014-02195 plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome… CVSS 2.0HIGH 7.8
- TI-2026-31684 Resource allocation without limits in Prosody CVSS 3.1HIGH 7.5
- TI-2021-15483 muc.lib.lua in Prosody 0.11.0 through 0.11.9 allows remote attackers to obtain sensitive… CVSS 3.1HIGH 7.5
Sources
- CVE-2026-43506 · CVE Program
- CVE-2026-43506 · NVD
- FIRST EPSS
- GHSA-q553-9xvw-ww8h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-43506 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences