Read the docs
TI-2022-00278 Aliases CVE-2022-0352GHSA-h56g-v4vp-q9q6

Cross-site Scripting (XSS) - Reflected in janeczku/calibre-web

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Why it matters now

EPSS 0.00853 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed janeczku/calibre-web (janeczku): 0.6.16calibreweb (PyPI): 0.6.16

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
janeczkujaneczku/calibre-webbefore 0.6.160.6.16Patch availableCNA
—calibreweb (PyPI)before 0.6.160.6.16Patch availableGHSA-h56g-v4vp-q9q6
  • janeczku/calibre-web Vendorjaneczku Affected before 0.6.16 Fixed in 0.6.16 Patch available CNA
  • calibreweb (PyPI) Vendor— Affected before 0.6.16 Fixed in 0.6.16 Patch available GHSA-h56g-v4vp-q9q6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:janeczku:calibre-web:*:*:*:*:*:*:*:*before 0.6.16Vulnerablejaneczku
  • cpe:2.3:a:janeczku:calibre-web:*:*:*:*:*:*:*:* Versions before 0.6.16 Vulnerable ·janeczku

Remediation

  • Fix · CNA janeczku/calibre-web (janeczku) Fixed in 0.6.16
  • Fix · GHSA-h56g-v4vp-q9q6 calibreweb (PyPI) Fixed in 0.6.16 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0352
  2. 2026-10-03 Alias added: GHSA-h56g-v4vp-q9q6

References

  • TI-2023-01981 Weak Password Requirements in janeczku/calibre-web CVSS 3.1CRITICAL 9.8
  • TI-2022-02333 Improper Restriction of Excessive Authentication Attempts in janeczku/calibre-web CVSS 3.1CRITICAL 9.8
  • TI-2021-07971 Calibre-web - Admin Account Takeover via Cross-Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2025-06745 Calibre Web 0.6.24 & Autocaliweb 0.7.0 - Blind C CVSS 4.0MEDIUM 5.9
  • TI-2021-02885 Cross-site Scripting (XSS) in janeczku/calibre-web CVSS 3.1MEDIUM 6.1
  • TI-2024-26178 In janeczku Calibre-Web 0.6.0 to 0.6.21, the edit_book_comments function is vulnerable to… CVSS 3.1MEDIUM 5.4
See all 23 →

Sources