TI WooCommerce Wishlist < 1.40.1 - Unauthenticated Blind SQL Injection
Priority HIGH 80CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The TI WooCommerce Wishlist WordPress plugin before 1.40.1, TI WooCommerce Wishlist Pro WordPress plugin before 1.40.1 do not sanitise and escape the item_id parameter before using it in a SQL statement via the wishlist/remove_product REST endpoint, allowing unauthenticated attackers to perform SQL injection attacks
Why it matters now
EPSS 0.73998 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed TI WooCommerce Wishlist (TemplateInvaders): 1.40.1TI WooCommerce Wishlist Pro (TemplateInvaders): 1.40.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| templateinvaders | TI WooCommerce Wishlist | 1.40.1 to before 1.40.1 | 1.40.1 | Patch available | CNA |
| templateinvaders | TI WooCommerce Wishlist Pro | 1.40.1 to before 1.40.1 | 1.40.1 | Patch available | CNA |
- TI WooCommerce Wishlist Vendortemplateinvaders Affected 1.40.1 to before 1.40.1 Fixed in 1.40.1 Patch available CNA
- TI WooCommerce Wishlist Pro Vendortemplateinvaders Affected 1.40.1 to before 1.40.1 Fixed in 1.40.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:templateinvaders:ti_woocommerce_wishlist:*:*:*:*:*:wordpress:*:* | before 1.40.1 | Vulnerable | templateinvaders |
| cpe:2.3:a:templateinvaders:ti_woocommerce_wishlist:*:*:*:*:pro:wordpress:*:* | before 1.40.1 | Vulnerable | templateinvaders |
- cpe:2.3:a:templateinvaders:ti_woocommerce_wishlist:*:*:*:*:*:wordpress:*:* Versions before 1.40.1 Vulnerable ·templateinvaders
- cpe:2.3:a:templateinvaders:ti_woocommerce_wishlist:*:*:*:*:pro:wordpress:*:* Versions before 1.40.1 Vulnerable ·templateinvaders
Remediation
- Fix · CNA TI WooCommerce Wishlist (TemplateInvaders) Fixed in 1.40.1
- Fix · CNA TI WooCommerce Wishlist Pro (TemplateInvaders) Fixed in 1.40.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0412
- 2026-10-03 Alias added: GHSA-h2g7-6p9r-jg23
References
More templateinvaders Ti Woocommerce Wishlist vulnerabilities
- TI-2024-29506 WordPress TI WooCommerce Wishlist plugin <= 2.8.2 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-08501 TI WooCommerce Wishlist <= 2.8.2 - Unauthenticated SQL Injection via lang parameters CVSS 3.1HIGH 7.5
- TI-2020-18896 TI WooCommerce Wishlist <= 1.21.11 and TI WooCommerce Wishlist Pro <= 1.21.4 - Arbitrary Options Update CVSS 3.1HIGH 8.8
Sources
- CVE-2022-0412 · CVE Program
- CVE-2022-0412 · NVD
- FIRST EPSS
- GHSA-h2g7-6p9r-jg23 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences