TI WooCommerce Wishlist <= 2.8.2 - Unauthenticated SQL Injection via lang parameters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The TI WooCommerce Wishlist WordPress plugin through 2.8.2 is vulnerable to SQL Injection due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | TI WooCommerce Wishlist | up to 2.8.2 | — | No fix listed | CNA |
- TI WooCommerce Wishlist VendorUnknown Affected up to 2.8.2 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:templateinvaders:ti_woocommerce_wishlist:*:*:*:*:free:wordpress:*:* | up to 2.8.2 | Vulnerable | templateinvaders |
- cpe:2.3:a:templateinvaders:ti_woocommerce_wishlist:*:*:*:*:free:wordpress:*:* Versions up to 2.8.2 Vulnerable ·templateinvaders
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9156
- 2026-10-03 Alias added: GHSA-37wv-xpm8-wf7h
References
More templateinvaders Ti Woocommerce Wishlist vulnerabilities
- TI-2022-00337 TI WooCommerce Wishlist < 1.40.1 - Unauthenticated Blind SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-29506 WordPress TI WooCommerce Wishlist plugin <= 2.8.2 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2020-18896 TI WooCommerce Wishlist <= 1.21.11 and TI WooCommerce Wishlist Pro <= 1.21.4 - Arbitrary Options Update CVSS 3.1HIGH 8.8
Sources
- CVE-2024-9156 · CVE Program
- CVE-2024-9156 · NVD
- FIRST EPSS
- GHSA-37wv-xpm8-wf7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences