Read the docs
TI-2022-00342 Aliases CVE-2022-0418GHSA-p96g-c878-c43j

Event List < 0.8.8 - Admin+ Stored Cross-Site Scripting

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Event List WordPress plugin before 0.8.8 does not sanitise and escape some of its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks against other admin even when the unfiltered_html is disallowed

Why it matters now

EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Event List (Unknown): 0.8.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownEvent List0.8.8 to before 0.8.80.8.8Patch availableCNA
  • Event List VendorUnknown Affected 0.8.8 to before 0.8.8 Fixed in 0.8.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:event_list_project:event_list:*:*:*:*:*:wordpress:*:*before 0.8.8VulnerableEvent List Project
  • cpe:2.3:a:event_list_project:event_list:*:*:*:*:*:wordpress:*:* Versions before 0.8.8 Vulnerable ·Event List Project

Remediation

  • Fix · CNA Event List (Unknown) Fixed in 0.8.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0418
  2. 2026-10-03 Alias added: GHSA-p96g-c878-c43j

References

  • TI-2017-06841 SQL injection vulnerability in the Event List plugin 0.7.8 for WordPress allows an… CVSS 3.0HIGH 8.8
  • TI-2017-08863 The Event List plugin 0.7.9 for WordPress has XSS in the slug array parameter to… CVSS 3.0MEDIUM 6.1

Sources