Read the docs
TI-2022-00358 Aliases CVE-2022-0434GHSA-qhcq-6xcp-843h

Page Views Count < 2.4.15 - Unauthenticated SQL Injection

Priority MEDIUM 58CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The Page View Count WordPress plugin before 2.4.15 does not sanitise and escape the post_ids parameter before using it in a SQL statement via a REST endpoint, available to both unauthenticated and authenticated users. As a result, unauthenticated attackers could perform SQL injection attacks

Why it matters now

EPSS 0.14783 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Page View Count (Unknown): 2.4.15

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPage View Count2.4.15 to before 2.4.152.4.15Patch availableCNA
  • Page View Count VendorUnknown Affected 2.4.15 to before 2.4.15 Fixed in 2.4.15 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:a3rev:page_view_count:*:*:*:*:*:wordpress:*:*before 2.4.15Vulnerablea3rev
  • cpe:2.3:a:a3rev:page_view_count:*:*:*:*:*:wordpress:*:* Versions before 2.4.15 Vulnerable ·a3rev

Remediation

  • Fix · CNA Page View Count (Unknown) Fixed in 2.4.15

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0434
  2. 2026-10-03 Alias added: GHSA-qhcq-6xcp-843h

References

  • TI-2023-00091 Page View Count < 2.6.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2025-02460 Page View Count 2.8.0 - 2.8.4 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update CVSS 3.1HIGH 8.1
  • TI-2021-06796 Page View Counts < 2.4.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-19021 WordPress Page View Count plugin <= 2.5.5 - Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 5.4

Sources