CP Blocks < 1.0.15 - Admin+ Stored Cross-Site Scripting
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The CP Blocks WordPress plugin before 1.0.15 does not sanitise and escape its "License ID" settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed.
Why it matters now
EPSS 0.05725 93rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed CP Blocks (Unknown): 1.0.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | CP Blocks | 1.0.15 to before 1.0.15 | 1.0.15 | Patch available | CNA |
- CP Blocks VendorUnknown Affected 1.0.15 to before 1.0.15 Fixed in 1.0.15 Patch available CNA
Remediation
- Fix · CNA CP Blocks (Unknown) Fixed in 1.0.15
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0448
- 2026-10-03 Alias added: GHSA-73r6-jqf2-wh3h
References
More dwbooster Cp Blocks vulnerabilities
- TI-2023-22147 WordPress CP Blocks Plugin <= 1.0.20 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2022-0448 · CVE Program
- CVE-2022-0448 · NVD
- FIRST EPSS
- GHSA-73r6-jqf2-wh3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences