E2Pdf < 1.16.45 - Admin+ Stored Cross-Site Scripting (XSS)
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The E2Pdf WordPress plugin before 1.16.45 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.01262 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed E2Pdf – Export To Pdf Tool for WordPress (Unknown): 1.16.45
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | E2Pdf – Export To Pdf Tool for WordPress | 1.16.45 to before 1.16.45 | 1.16.45 | Patch available | CNA |
- E2Pdf – Export To Pdf Tool for WordPress VendorUnknown Affected 1.16.45 to before 1.16.45 Fixed in 1.16.45 Patch available CNA
Remediation
- Fix · CNA E2Pdf – Export To Pdf Tool for WordPress (Unknown) Fixed in 1.16.45
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0535
- 2026-10-03 Alias added: GHSA-48h4-gmhg-hvjg
References
More E2pdf vulnerabilities
- TI-2023-04807 E2Pdf < 1.20.20 - Admin+ Stored Cross-Site Scriping CVSS 3.1MEDIUM 4.8
- TI-2023-06233 E2Pdf <= 1.20.25 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2023-27754 WordPress e2pdf Plugin <= 1.20.23 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2023-24795 WordPress e2pdf Plugin <= 1.20.18 is vulnerable to PHP Object Injection CVSS 3.1HIGH 7.2
- TI-2025-38391 WordPress e2pdf plugin <= 1.28.09 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-28970 WordPress E2Pdf – Export To Pdf Tool for WordPress plugin <= 1.25.05 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-0535 · CVE Program
- CVE-2022-0535 · NVD
- FIRST EPSS
- GHSA-48h4-gmhg-hvjg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences