E2Pdf < 1.20.20 - Admin+ Stored Cross-Site Scriping
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The E2Pdf WordPress plugin before 1.20.20 does not sanitize and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00475 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed E2Pdf (Unknown): 1.20.20
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | E2Pdf | before 1.20.20 | 1.20.20 | Patch available | CNA |
- E2Pdf VendorUnknown Affected before 1.20.20 Fixed in 1.20.20 Patch available CNA
Remediation
- Fix · CNA E2Pdf (Unknown) Fixed in 1.20.20
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5229
- 2026-10-03 Alias added: GHSA-m9r2-v6px-98w2
References
More E2pdf vulnerabilities
- TI-2023-06233 E2Pdf <= 1.20.25 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2023-27754 WordPress e2pdf Plugin <= 1.20.23 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2023-24795 WordPress e2pdf Plugin <= 1.20.18 is vulnerable to PHP Object Injection CVSS 3.1HIGH 7.2
- TI-2025-38391 WordPress e2pdf plugin <= 1.28.09 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-28970 WordPress E2Pdf – Export To Pdf Tool for WordPress plugin <= 1.25.05 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2022-00455 E2Pdf < 1.16.45 - Admin+ Stored Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-5229 · CVE Program
- CVE-2023-5229 · NVD
- FIRST EPSS
- GHSA-m9r2-v6px-98w2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences