Improper Validation of Specified Quantity in Input in microweber/microweber
Priority LOW 21CWE-1284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.
Why it matters now
EPSS 0.0062 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed microweber/microweber (microweber): 1.2.11microweber/microweber (Packagist): 1.2.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| microweber | microweber/microweber | before 1.2.11 | 1.2.11 | Patch available | CNA |
| — | microweber/microweber (Packagist) | before 1.2.11 | 1.2.11 | Patch available | GHSA-vpq7-m4qm-p2gp |
- microweber/microweber Vendormicroweber Affected before 1.2.11 Fixed in 1.2.11 Patch available CNA
- microweber/microweber (Packagist) Vendor— Affected before 1.2.11 Fixed in 1.2.11 Patch available GHSA-vpq7-m4qm-p2gp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* | before 1.2.11 | Vulnerable | microweber |
- cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* Versions before 1.2.11 Vulnerable ·microweber
Remediation
- Fix · CNA microweber/microweber (microweber) Fixed in 1.2.11
- Fix · GHSA-vpq7-m4qm-p2gp microweber/microweber (Packagist) Fixed in 1.2.11 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
microweber/microweber 1.2.11
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-00514 Open Redirect in microweber/microweberPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0596
- 2026-10-03 Alias added: GHSA-vpq7-m4qm-p2gp
References
More Microweber vulnerabilities
- TI-2023-01763 Command Injection in microweber/microweber CVSS 3.1CRITICAL 9.8
- TI-2023-02100 Improper Privilege Management in microweber/microweber CVSS 3.1HIGH 8.8
- TI-2022-14518 Microweber v1.2.15 was discovered to allow attackers to perform an account takeover via a host header injection attack. CVSS 3.1HIGH 8.8
- TI-2023-04891 Use of Hard-coded Credentials in microweber/microweber CVSS 3.1HIGH 7.5
- TI-2025-37870 Microweber CMS 2.0 has Weak Password Requirements. CVSS 3.1HIGH 8.3
- TI-2022-04247 Cross-site Scripting (XSS) - Stored in microweber/microweber CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-0596 · CVE Program
- CVE-2022-0596 · NVD
- FIRST EPSS
- GHSA-vpq7-m4qm-p2gp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences