Print, PDF, Email by PrintFriendly < 5.2.3 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Print, PDF, Email by PrintFriendly WordPress plugin before 5.2.3 does not sanitise and escape the Custom Button Text settings, which could allow high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00588 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Print, PDF, Email by PrintFriendly (Unknown): 5.2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Print, PDF, Email by PrintFriendly | 5.2.3 to before 5.2.3 | 5.2.3 | Patch available | CNA |
- Print, PDF, Email by PrintFriendly VendorUnknown Affected 5.2.3 to before 5.2.3 Fixed in 5.2.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:printfriendly:print\,_pdf\,_email_by_printfriendly:*:*:*:*:*:wordpress:*:* | before 5.2.3 | Vulnerable | printfriendly |
- cpe:2.3:a:printfriendly:print\,_pdf\,_email_by_printfriendly:*:*:*:*:*:wordpress:*:* Versions before 5.2.3 Vulnerable ·printfriendly
Remediation
- Fix · CNA Print, PDF, Email by PrintFriendly (Unknown) Fixed in 5.2.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0663
- 2026-10-03 Alias added: GHSA-54m9-2jf4-c8x9
References
More printfriendly Print, Pdf, Email By Printfriendly vulnerabilities
- TI-2023-10505 WordPress Print, PDF, Email by PrintFriendly Plugin <= 5.5.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-0663 · CVE Program
- CVE-2022-0663 · NVD
- FIRST EPSS
- GHSA-54m9-2jf4-c8x9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences