Read the docs
TI-2022-00780 Aliases CVE-2022-0875GHSA-vwfv-wx8q-xqpc

miniOrange Google Authenticator < 1.0.5 - CSRF to Stored Cross-Site Scripting

Priority LOW 20CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The Google Authenticator WordPress plugin before 1.0.5 does not have CSRF check when saving its settings, and does not sanitise as well as escape them, allowing attackers to make a logged in admin change them and perform Cross-Site Scripting attacks

Why it matters now

EPSS 0.00429 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Google Authenticator (Unknown): 1.0.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownGoogle Authenticator1.0.5 to before 1.0.51.0.5Patch availableCNA
  • Google Authenticator VendorUnknown Affected 1.0.5 to before 1.0.5 Fixed in 1.0.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:miniorange:google_authenticator:*:*:*:*:*:wordpress:*:*before 1.0.5VulnerableminiOrange
  • cpe:2.3:a:miniorange:google_authenticator:*:*:*:*:*:wordpress:*:* Versions before 1.0.5 Vulnerable ·miniOrange

Remediation

  • Fix · CNA Google Authenticator (Unknown) Fixed in 1.0.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0875
  2. 2026-10-03 Alias added: GHSA-vwfv-wx8q-xqpc

References

  • TI-2022-04534 miniOrange's Google Authenticator <= 5.6.5 - Missing Authorization to Plugin Settings Change CVSS 3.1HIGH 7.5
  • TI-2022-20660 WordPress miniOrange's Google Authenticator plugin <= 5.6.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2022-21926 WordPress miniOrange's Google Authenticator Plugin <= 5.6.1 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 8.1
  • TI-2022-00165 miniOrange's Google Authenticator < 5.5 - Unauthenticated Arbitrary Options Deletion CVSS 3.1HIGH 8.1
  • TI-2022-01203 miniOrange's Google Authenticator < 5.5.6 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8

Sources